Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Ok I have IIS fully working, on my internal IP.

However, no matter what I do, it seems to ignore external IP access.

I have forwarded port 80 onto my internel IP, and it works with XAMPP. After closing XAMPP and booting IIS (IIS makes it a lot easier to upload Visual Studio stuff that updates), it doesn't allow the access.

share|improve this question
    
You are sure you are not being blocked by a firewall? –  Campo Mar 9 '11 at 18:04
    
Well AVG seems to have no firewall. I'll disable my windows firewall see if that helps. –  Ashley Davies Mar 9 '11 at 18:13
    
Wow, I'm depressed now. It's my firewall, but I have no clue how to allow the service through since it doesn't show up on the list and I have no idea where the file is located since view file location isn't showing on the right click menu. –  Ashley Davies Mar 9 '11 at 18:14
    
Found. Which exe do I allow through? Inetmanager.exe, appcmd.exe, there's quite a few. –  Ashley Davies Mar 9 '11 at 18:16
    
Open port 80 on your firewall and it should work.... I am making this the answer –  Campo Mar 9 '11 at 18:28

2 Answers 2

up vote 2 down vote accepted

Make sure your firewall is open....

Check your windows firewall as well as your hardware firewalls....

If you turn off your windows firewall and it works it is most certainly that....

You must open port 80 on the windows firewall to allow HTTP traffic through.

For windows 7

For Xp

You did not specify this was on a windows server please let us know if it is and I will link the appropriate guide for the Firewall

share|improve this answer

First make sure that you can ping the external IP, also make sure that the firewall (physical or Windows Firewall) isn't blocking port 80 (and 443 for SSL). And make sure that you added the correct bindings to the site for the external IP. Here's a quick video walkthrough.

share|improve this answer
    
canyouseeme.org found the port open. The bindings are set to dafault (*). As I said, XAMPP worked fine, but IIS isn't. –  Ashley Davies Mar 9 '11 at 18:12

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.