Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a maintenance plan setup for a databases on a server. As part of the backup is a Maintenance Cleanup Task.

SQL Version 2008

The task that 'succeeds' is setup as:

Delete backup files
Correct folder (same address as the backup task)
File extension: bak (NOT .bak)
Delete files older than: 20 Hour(s)

I have other similar cleanup tasks that occur in the same maintenance plan which work fine. This plan has worked fine in the past, I just noticed that last night it reported 'success' and the rest of the plan continued, however the file from 2 days ago still remains.

I have checked similar questions such as this question, and this is not the case as my maintenance task worked fine two days ago and for the past several weeks:

share|improve this question

1 Answer 1

up vote 0 down vote accepted

Check the file to see if it is a valid backup file. If the file is corrupt or in some other way damaged the process to remove the file won't do anything. You can check it by doing:

RESTORE HEADERONLY FROM DISK='d:\Path\To\Your\File.bak'
share|improve this answer
    
Thanks, this seems to have been the issue, the backup part of the plan was not ensuring the backups were valid. –  Seph Mar 10 '11 at 6:37

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.