Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

We have a TFS 2008 running on a SQL Server 2008 as base (Windows Server 2003 R2 32 Bit Version).

Short time ago I discovered that the Warhouse data (used by reports and analyzer Service) isn't updated. becouse we nearly never used the reports it's broken sinse " September 2010"

If I check the Server logs i find the following event Msg:

Date (UTC): 10.03.2011 11:28:06
Application Domain: /LM/W3SVC/1048316701/Root/Warehouse-5-129441362809652769
Assembly: Microsoft.TeamFoundation.Warehouse, Version=, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a; v2.0.50727
Process Details:
  Process Name: w3wp
  Process Id: 3116
  Thread Id: 3268
  Account name: ourdomain\generic

Detailed Message: The pending configuration changes were not successfully added to the cube because of the following error: 
System.SystemException: The trust relationship between the primary domain and the trusted domain failed.

   at System.Security.Principal.NTAccount.TranslateToSids(IdentityReferenceCollection sourceAccounts, Boolean& someFailed)
   at System.Security.Principal.NTAccount.Translate(IdentityReferenceCollection sourceAccounts, Type targetType, Boolean& someFailed)
   at System.Security.Principal.NTAccount.Translate(IdentityReferenceCollection sourceAccounts, Type targetType, Boolean forceSuccess)
   at System.Security.Principal.NTAccount.Translate(Type targetType)
   at Microsoft.TeamFoundation.Warehouse.OlapCreator.AddAccountToRole(Role role, String accountName, Boolean needToUpdate)
   at Microsoft.TeamFoundation.Warehouse.OlapCreator.SetupAnalysisDatabase(Server server, String analysisDBName, String accessUser, String[] dataReaderAccounts)
   at Microsoft.TeamFoundation.Warehouse.OlapCreator.CreateOlap(WarehouseConfig whConf, String accessUser, String[] dataReaderAccounts, Boolean dropDB, Boolean processCube)
   at Microsoft.TeamFoundation.Warehouse.AdapterScheduler.EnsureCubeIsUpToDate()

For more information, see Help and Support Center at

Somebody have a clue what to do? Restarting the services AND the server didn't helped.

share|improve this question

currently im migrating our company TFS and while im going through this hellish expreience , i encountered your error in 1 of the first steps.

some googling found me a couple of solutions but none of them worked , the only thing that solved it was the remove the server from the domain and join the domain again.

Hope youll find this useful.

share|improve this answer
Hi I read somwhere else about this solution but I didn't tried it. We are upgrading/Migrating to Sever 2010, so we don't spend time with this topic any more – nobs Jul 22 '11 at 6:50

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.