Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

HI I've an old Dell poweredge server with an CDROM drive. I've attached a USB DVDROM and USB stick with my ks.cfg on so I can install RHEL from DVD not loads of CDs :-)

I can boot from the RHEL media in DVDROM and point the installer to the USB ks.cfg. This works but the ks.cfg script has the cdrom keyword in it. The install then stops and asks for the RHEL media to be in the CDROM drive not the DVDROM.

How can I change the ks.cfg so it uses the external DVDROM for the install media not servers builtin cdrom drive ?

I know I can go and rebuild my DVD image to include the ks.cfg , but this is an extra step I dont want to do if I have to.

Regards Andy

share|improve this question
add comment

2 Answers

up vote 1 down vote accepted

Use:

ks=cdrom:<device>

As your ks= option. The documentation on this is not consistant, so I'm grasping at straws here... Some docs say you specify a device after the colon, others say you specify a file. See http://fedoraproject.org/wiki/Anaconda/Options for more info.

You might also try

ks=hd:<device>:/<file>
share|improve this answer
    
The ks= is not the problem , as its reading the ks.cfg . Inside the ks.cfg i have a line whichsays cdrom , but its using the wrong device for the install media –  AndyM Mar 10 '11 at 15:37
    
Oh. What happens if you remove the cdrom line? –  JeffG Mar 11 '11 at 0:22
    
if you can, figure out what device the externam drive is detected as and replace the cdrom line with harddrive --partition=sdc1 --dir=/tmp/install-tree. [Example assumes /dev/sdc1 is your external CD's partition] This page fedoraproject.org/wiki/Anaconda/Kickstart#install says that cdrom always uses the first cd drive. –  JeffG Mar 11 '11 at 0:28
    
Cheers I'll give that try –  AndyM Mar 14 '11 at 11:43
    
If you have no luck, you might also format your DVd using ext2 instead of ISO. –  JeffG Mar 14 '11 at 13:21
add comment

You can try disabling the internal CD-ROM in BIOS. As JeffG has already mentioned, Anaconda uses the first device.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.