Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am getting following notices in php errorlog file.

[10-Mar-2011 13:58:39] PHP Notice:  require_once() [<a href='function.require-once'>function.require-once</a>]: 1. h-&gt;opened_path=[/home/www/XXXXX/Core/QAjax.php]  h-&gt;filename=[/home/www/XXXXX/include/project/Core/QAjax.php]
 in /home/www/XXXXX/modules/quantum_bootstrap.php on line 54
[10-Mar-2011 13:58:39] PHP Notice:  require_once() [<a href='function.require-once'>function.require-once</a>]: 1. h-&gt;opened_path=[/home/www/XXXXX/Core/Memcache.php]  h-&gt;filename=[/home/www/XXXXX/Core/Memcache.php]
 in /home/www/XXXXX/include/project/Core/QAjax.php on line 22
[10-Mar-2011 13:58:41] PHP Notice:  require_once() [<a href='function.require-once'>function.require-once</a>]: 1. h-&gt;opened_path=[/home/www/XXXXX/cache/Parameters.php]  h-&gt;filename=[/home/www/XXXXX/include/cache/Parameters.php]
 in /home/www/XXXXX/include/modules/quantum_bootstrap.php on line 15
[10-Mar-2011 13:58:41] PHP Notice:  require_once() [<a href='function.require-once'>function.require-once</a>]: 1. h-&gt;opened_path=[/home/www/XXXXX/include/modules/headers.php]  h-&gt;filename=[/home/www/XXXXX/include/modules/headers.php]
 in /home/www/XXXXX/include/modules/quantum_bootstrap.php on line 17

However, I turned off notices in php.ini:

error_reporting = E_ALL & ~E_NOTICE

When I switch it only to E_ERROR it is also in the log.

I am using php-cgi and folowing extensions:

Installed packages, channel pecl.php.net:
=========================================
Package   Version State
APC       3.1.7   beta
gearman   0.7.0   beta
memcache  2.2.6   stable
memcached 1.0.2   stable

Installed packages, channel pear.php.net:
=========================================
Package          Version  State
Archive_Tar      1.3.7    stable
Console_Getopt   1.3.1    stable
Log              1.12.5   stable
PEAR             1.9.2    stable
Structures_Graph 1.0.4    stable
System_Daemon    1.0.0RC1 beta
XML_Util         1.2.1    stable
share|improve this question
    
Which php version do you use? And how looks one of these lines where the error happen? –  Stony Mar 10 '11 at 14:03
    
PHP 5.3.5 (cgi-fcgi) 22: require_once(CPARAM_APPLICATION_ROOT.'include/project/Core/Memcache.php'); 54: require_once(CPARAM_APPLICATION_ROOT.'include/project/Core/QAjax.php'); 15:require_once dirname(__FILE__).'/../../include/cache/Parameters.php'; 17: require_once (CPARAM_APPLICATION_ROOT.'/include/modules/headers.php'); –  csgwro Mar 10 '11 at 14:31
add comment

1 Answer

Problem solved ourself. There was a redefining directive in php script

error_reporting(E_ALL);

However I still don't know why it's classify as "PHP Notice".

share|improve this answer
    
There is bug in APC 3.1.7 always setting APC in debug mode (even if we choose no). –  csgwro Mar 10 '11 at 16:03
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.