Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

kind of a newbie to server stuff.

I am running a centOS setup with whoosh search engine for my django app. Everytime I restart or rebuild my index i get a warning that states IOError: The path to your Whoosh index '/www/test/mysite_index' is not writable for the current user/group.

How do I make sure this folder stays permanently CHMOD'd

Thanks

share|improve this question

2 Answers 2

Chmod is already permanent.
The fact that the permissions change means that another process or user changes the permissions back behind your back.

Beside that, it's probably a better idea to use the chown command to change the owner of the folder.

share|improve this answer

There could be a few options: Try looking at the umask for the user/process that creates the file.

You also want to look at the group owner of the file and the processes that are trying to read it , should they be in the same group ?

Failing that then look at adding a chmod command to a script just after the file is created as part of its creation script.

share|improve this answer
    
I'm sure you meant umask, not "unmask" :) –  0xC0000022L Mar 10 '11 at 13:58
    
yes sorry , typo –  AndyM Mar 10 '11 at 14:00
    
you can edit your own answer ;) –  0xC0000022L Mar 10 '11 at 15:06

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.