Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Apologies if this is already answered, its a tricky one to search for! We are using split DNS for a domain used internally. For the outside nameservers, theres a simple zone with:

@   IN A ip.ad.dr.ess
www IN A ip.ad.re.ss

This works fine externally. Internally its a windows server 2003 DNS server, so the www a record works fine, but I cant figure out how to add that primary record (using at symbol @ in bind).

Can anyone help with how to get the same results from windows dns? I just want to be able to add a record for example.com without being forced to use something.example.com

Thanks,

Edit: This domain is not the "main" AD domain, and not used for logins etc.

Edit: I was attempting to update the zone on another server (zone is ad integrated, so shouldnt matter?) getting the error. Adding it to the same zone on another AD server worked. Not sure if it makes a difference, but this server that it worked on currently holds all fsmo roles.

share|improve this question
    
What do you get when you query DNS about the base domain name, currently? Is there, for example, a hidden CNAME record bedeviling your attempts to add this one? –  BMDan May 30 at 18:03
add comment

2 Answers

up vote 0 down vote accepted

Create an A record in the zone and leave the "Name" field blank.

share|improve this answer
    
Thanks Jason - When I do this, it fails with "There was a server failure" - is this because of a messed up zone, or its demanding a record value? –  captainmish Mar 10 '11 at 15:40
    
We're using a similar approach as you with split DNS for internal and external purposes. As a test I've just added a root host record as per Jason's answerand it worked fine. This was a Windows Server 2008 R2 DNS server however. –  Lewis Mar 10 '11 at 16:56
    
Thanks Lewis, I can start to guess that something is broken in this zone then. Is yours an active directory integrated zone as well? –  captainmish Mar 10 '11 at 17:03
add comment

Is your Active Directory domain using example.com internally? If so, there are already A records for example.com that point to the domain controllers; you can't remove these without breaking domain function.

share|improve this answer
    
Hi Shane, sorry I didnt specify that on the original question, now edited - the domain is not the primary active directory domain, and is not being used in active directory at all, its just for name service. –  captainmish Mar 10 '11 at 15:41
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.