Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Ive been trying to install gitorious for a while now which required ruby and rails etc. Ive finally got rails pages serving but cant finish the installation of gitorious because the gem version is too new.

the error logs say please run 'rake ultrasphinx:configure'

and that gives

rake ultrasphinx:configure
(in /var/www/apps/gitorious)
rake aborted!
uninitialized constant ActiveSupport::Dependencies::Mutex
/var/www/apps/gitorious/Rakefile:10:in `require'
(See full trace by running task with --trace)

From searching google this is beacuse of the wrong gem verison. Cant find a way to down grade it.

apparently sudo gem update --system 1.4.2 should do the trick but ubuntu 10.10 does not like this.

ERROR:  While executing gem ... (RuntimeError)
    gem update --system is disabled on Debian, because it will overwrite the content of the rubygems Debian package, and might break your Debian system in subtle ways. The Debian-supported way to update rubygems is through apt-get, using Debian official repositories.
If you really know what you are doing, you can still update rubygems by setting the REALLY_GEM_UPDATE_SYSTEM environment variable, but please remember that this is completely unsupported by Debian.

So i added export REALLY_GEM_UPDATE_SYSTEM=1 to .bashrc and reloaded it with . ~/.bashrc and still the same. ive tried various forms of setting this environmental variable with no luck.

Ive also been told on #gitorious irc channel to add the file config/initializers/rubygems.rb with the line require "thread" to it. This has done nothing.

EDIT: Just found another way which was rvm install rubygems 1.4.2

and it gave:

Removing old Rubygems files...
Installing rubygems dedicated to ruby-1.8.7-p334...
Retrieving rubygems-1.4.2
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100  288k  100  288k    0     0   282k      0  0:00:01  0:00:01 --:--:--  414k
Extracting rubygems-1.4.2 ...
Installing rubygems for /home/ubuntu/.rvm/rubies/ruby-1.8.7-p334/bin/ruby
ERROR: Error running 'GEM_PATH="/home/ubuntu/.rvm/gems/ruby-1.8.7-p334:/home/ubuntu/.rvm/gems/ruby-1.8.7-p334@global:/home/ubuntu/.rvm/gems/ruby-1.8.7-p334@global" GEM_HOME="/home/ubuntu/.rvm/gems/ruby-1.8.7-p334" "/home/ubuntu/.rvm/rubies/ruby-1.8.7-p334/bin/ruby" "/home/ubuntu/.rvm/src/rubygems-1.4.2/setup.rb"', please read /home/ubuntu/.rvm/log/ruby-1.8.7-p334/rubygems.install.log
WARN: Installation of rubygems did not complete successfully.

TL;DR please tell me how to downgrade rubygems on ubuntu 10.10 or upgrade gitorious to work with 1.6.2 gems

share|improve this question
add comment

4 Answers

You can also try the BitNami installer for Gitorious. It is self-contained and independent of your system. It installs everything that you need to run Gitorious in your own machine.

share|improve this answer
add comment

I think the proper way of doing it is:

rvm rubygems 1.4.2

That tells rvm to change the version of rubygems, instead of trying to install one.

share|improve this answer
add comment

I've had the same problem. Now there are two additional installation guides on top of the installation guide page on gitorious:

Ubuntu 10.04

Ubuntu 11.04

That solved this and other problems in the installation process for me, hopefully this helps others too.

share|improve this answer
add comment
up vote 3 down vote accepted

nevermind... even though it says it failed, rvm install rubygems 1.4.2 has worked

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.