Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

First time going through this scenario, and apparently I did it very wrong. On the DB servers I deleted the cluster group that held SQL and Reporting Services. I then destroyed the cluster. Then I tried to uninstall SQL. No dice. SQL still thinks its part of the non-existant cluster and will not let me uninstall it. I went into the Maintenance menu of the SQL setup and tried to Remove Node...nope.

Unless I find a way out of this I will have to rebuild the OS if I can't get SQL off the box.

share|improve this question
Bob, it is possible to manually rebuild the SQL cluster; I've done it before. This is the cleanest way to later uninstall it. I have to warn you that rebuilding is a tedious process. You may be better off doing a new OS install if you don't need the database. If you want to try restoring the database, please let me know and I can post instructions first thing in the morning. Plese tell me which version of Windows and SQL you are using so I can provide the appropriate steps. – newmanth Mar 10 '11 at 23:13
I'm using SQL 2008 Standard. I didn't care about the DB, and ended up reinstalling the OS (which is VMWare consequently since this is just a dev environment). I still wouldn't mind knowing how this rebuild works. – Bob Mar 14 '11 at 14:37

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.