Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

There are a range of HP-UX 11.11 hosts I'm unable to install rsync (I'm limited to a non-privileged user)

I've extracted both rsync binary and libpopt.sl, libiconv.sl, libintl.sl from the depots into one of that user's directories: /home/zenith/rsync/

Problem is, I can't get my RH Linux box communicating with it:

rsync -e --rsync-path=/home/zenith/rsync/rsync --compress=9 -pgtov --filter=+rs_/'*.log' --exclude='*' zenith@192.102.14.18:/home/zenith/service/logs/ /u01/rsync_depot/service/192.102.14.18/

/usr/lib/dld.sl: Can't find path for shared library: libintl.sl
/usr/lib/dld.sl: No such file or directory
sh: 1644 Abort(coredump)

I've added to the remote host .profile

export SHLIB_PATH=/usr/lib:/home/zenith/rsync
export PATH=$PATH:/home/zenith/rsync

but still, no libintl.sl is found. How can I initialize the correct env variable/ get this to work?

share|improve this question

1 Answer 1

How about adding LD_LIBRARY_PATH variable and adding the directory where the shared library is?

share|improve this answer
    
mdpc, I've tried adding it but I still get a /usr/lib/dld.sl: Can't find path for shared library: libintl.sl /usr/lib/dld.sl: No such file or directory (that path contents are, -r-xr-x--- 1 zenith users 1019904 Mar 7 18:34 libiconv.sl -r-xr-x--- 1 zenith users 98304 Mar 7 18:31 libintl.sl -r-xr-x--- 1 zenith users 139264 Mar 7 18:35 libpopt.sl) –  Joao Figueiredo Mar 14 '11 at 10:24
    
The only ugly workaround I got so far was creating a BASH file named rsync (and renaming rsync bin to rsync.bin) export SHLIB_PATH=$SHLIB_PATH:/home/core/rsync /home/zenith/rsync/rsync.bin $1 $2 $3 $4 $5 $6 $7 $8 Any idea what's amiss? –  Joao Figueiredo Mar 14 '11 at 10:28

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.