Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

how can I set the Variable character_set_results from latin1 to uft8? I thought it would be enough to add the following variable in my.cnf:

default-character-set=utf8

But it not seem so:

mysql> SHOW VARIABLES LIKE 'character_set_%';
+--------------------------+----------------------------+
| Variable_name            | Value                      |
+--------------------------+----------------------------+
| character_set_client     | latin1                     |
| character_set_connection | latin1                     |
| character_set_database   | utf8                       |
| character_set_filesystem | binary                     |
| character_set_results    | latin1                     |
| character_set_server     | utf8                       |
| character_set_system     | utf8                       |
| character_sets_dir       | /usr/share/mysql/charsets/ |
+--------------------------+----------------------------+

Does anybody have an idea how I can set character_set_results to utf8?

share|improve this question

3 Answers 3

From this page:

It seems that the character-set-results and character-set-connection can't be set in the [mysqld] part of the config file. You have to put them in the [client] part.

I personally didn't try it.

share|improve this answer

The character set is negotiated between the client and the server on connect.

To prevent this and force the client and thus the server to use your configured character set:
[mysqld]
skip-character-set-client-handshake=1
default-character-set=utf8

share|improve this answer
    
I want to marry you. –  Matthew Scragg Nov 20 '13 at 16:47

with this settings it works:
[mysqld]
skip-character-set-client-handshake=1
default-character-set=utf8

Greetings Marc

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.