Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm trying to enable NTLM authentication on a Windows Server 2008 R2 machine with IIS 7.5 for a specific file in my web root. I've been following these instructions http://docs.moodle.org/en/NTLM_authentication#IIS_Configuration

In the IIS Manager I open the Authentication module, disable anonymous authentication and enable Windows Authentication however according to every post I can find on the matter I should have a 'providers' option appear but I don't.

I've double checked in Server Manager that the 'Windows Authentication' security feature is enabled for IIS.

Any help anyone can offer would be great,

Thank you!

share|improve this question
    
Are you attempting this EXACTLY like it says in the screenshot? I hate to be redundant, but I just installed a brand new IIS 7.5 on a VM, and the option is there. –  JohnThePro May 10 '12 at 21:35
    
and also, I hate to do it, but are you 100% positive you're running 2008R2? In Server 2008 (iis 7) there is no user interface for this functionality. –  JohnThePro May 10 '12 at 21:36

3 Answers 3

I had similar issue, after verification with other servers where i see this option I found out it's missing on Windows Server 2008. Whereas on Server 2008 R2 this option is available.

Regards, Przemek

share|improve this answer

When you enable Windows Authentication (and you have it selected), an option should appear on the right: http://d.pr/Zng5

You can also right-click and get the option as well.

Dan

share|improve this answer
    
That's the thing though, the Provider's option isn't there. I would try re-installing the Windows Authentication feature however the checkbox is disabled despite me being the administrator... –  Alex Bilbie Mar 11 '11 at 0:48
    
Here's a screenshot of what I get twitpic.com/48ahme/full –  Alex Bilbie Mar 11 '11 at 0:55

Perhaps you can't specify providers for an individual page? (that's what the screenshot's showing you trying to do).

First, try it at the Server or Site level; if they work, work your way down.

share|improve this answer
    
Page, Folder, or Site. It works on all levels. –  JohnThePro May 10 '12 at 21:36

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.