Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have enable snmp on linux (Fedora) but i can access only to system group. Why? Should I made changes in snmp.conf?

Thanks

share|improve this question

migrated from stackoverflow.com Mar 11 '11 at 2:03

This question came from our site for professional and enthusiast programmers.

1  
I guess Fedora ships net-snmp as default. You may check that. Then Net-SNMP web site can be your guide. net-snmp.org – Lex Li Mar 8 '11 at 12:46

Yes, you need to change the snmpd.conf file (note the d in snmp*d*.conf). The default fedora configuration only allows you access to the system group.

Run "snmpconf -g basic_setup" to get you started, which will walk you through setting up the needed configuration file.

Or if you're in a hurry, put this in your snmpd.conf file to use insecure SNMPv2c to allow access to the whole agent:

  rocommunity PICKYOURCOMMUNITYNAME
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.