Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have set up hosts.allow on the remote Arch Linux server as follows:

sshd: ALL: ALLOW

while hosts.deny is set to:


I have no problems using SSH through Cygwin (with a Corkscrew tunnel through a proxy server). When I open screen in Cygwin and try to SSH however, I receive the following error:

ssh_exchange_identification: Connection closed by remote host

The verbose output is as follows:

$ ssh -v [username]@[remote server]
OpenSSH_5.6p1, OpenSSL 0.9.8o 01 Jun 2010
debug1: Reading configuration data /etc/ssh_config
debug1: Applying options for *
debug1: Applying options for [remote server]
debug1: Executing proxy command: exec /usr/bin/corkscrew [proxy server] 80 [remote server] 443 ~/.corkscrew-auth
debug1: permanently_drop_suid: 152811
No such file or directory
debug1: identity file /home/[username]/.ssh/id_rsa type -1
debug1: identity file /home/[username]/.ssh/id_rsa-cert type -1
debug1: identity file /home/[username]/.ssh/id_dsa type -1
debug1: identity file /home/[username]/.ssh/id_dsa-cert type -1
ssh_exchange_identification: Connection closed by remote host

I've already tried removing the SSH keys from both the client and the server and I get the same error.

Like I said before, SSH works fine when I'm not using screen. I can't work out why the SSH connection is being dropped when it is run through screen though.

share|improve this question

I'm not sure your hosts.allow syntax is valid. Try:

sshd: ALL
share|improve this answer
Thanks, but I've tried that layout and I get the same error. – Shaun Taheri Mar 11 '11 at 14:33

Looks like corkscrew can't find configuration file ~/.corkscrew-auth or /usr/bin/corkscrew binary itself.

According to corkscrew manual page file ~/.corkscrew-auth should contain account info: username:password

share|improve this answer
Hi - thanks for your reply but Corkscrew is working fine (with the config located at ~/.corkscrew-auth), so the problem lies elsewhere. – Shaun Taheri Mar 14 '11 at 9:58
up vote 0 down vote accepted

I'm still not entirely sure where the problem was (i.e. with OpenSSH, Corkscrew, or somewhere else), however it has disappeared after updating Cygwin to the latest version of all packages.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.