Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

hello does anybody knows how to remove Apache to server maximum concurrent connections ? somebody told me that internal server error 500 is actually due to the maximum user processes set by default by cPanel. By Default, cPanel sets the maximum user process to 25 . all my websites are down due to internal server error . i think if i remove Apache to server maximum concurrent connections this problem will be resolved . please help me in this urgent problem

thank you

share|improve this question
add comment

1 Answer

Try these settings for apache :

/usr/local/apache/conf/httpd.conf

Under : IfModule worker.c

ThreadLimit 1000

MinSpareThreads 100

MaxSpareThreads 100

ServerLimit 2000

And mysql :

/etc/my.cnf

[mysqld]

max_connections=2000

max_user_connections=50

Keep and eye on the server load after you make these changes. Dont forget to run the apache distiller /usr/local/cpanel/bin/apache_conf_distiller

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.