Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

after setting up My vsFtp Server ON Ec2 i am facing problem , my client is Filezilla

and i am getting this error

Response:   230 Login successful.
Command:    OPTS UTF8 ON
Response:   200 Always in UTF8 mode.
Status: Connected
Status: Retrieving directory listing...
Command:    PWD
Response:   257 "/"
Command:    TYPE I
Response:   200 Switching to Binary mode.
Command:    PASV
Response:   500 OOPS: invalid pasv_address
Command:    PORT 10,130,8,44,240,50
Response:   500 OOPS: priv_sock_get_cmd
Error:  Failed to retrieve directory listing
Error:  Connection closed by server

this is the current setting in my vsftpd.conf

#nopriv_user=ftpsecure                                                                                                                          
#async_abor_enable=YES                                                                                                                                                                                                                                        
# ASCII mangling is a horrible feature of the protocol.                                                                                         
#ascii_upload_enable=YES                                                                                                                        
#ascii_download_enable=YES                                                                                                                                                                                                                                                
# You may specify a file of disallowed anonymous e-mail addresses. Apparently                                                                   
# useful for combatting certain DoS attacks.                                                                                                    
#deny_email_enable=YES                                                                                                                          
# (default follows)                                                                                                                             
#banned_email_file=/etc/vsftpd/banned_emails                                                                                                    
#                                                                                                                                                                                                                                                           
chroot_local_user=YES                                                                                                                           
#chroot_list_enable=YES                                                                                                                         
# (default follows)                                                                                                                             
#chroot_list_file=/etc/vsftpd/chroot_list                                                                                                       
  GNU nano 2.0.6                               File: /etc/vsftpd/vsftpd.conf                                                                    

#                                                                                                                                                               #ls_recurse_enable=YES                                                                                                                          
#                                                                                          
# When "listen" directive is enabled, vsftpd runs in standalone mode and                                                                        
# listens on IPv4 sockets. This directive cannot be used in conjunction                                                                         
# with the listen_ipv6 directive.                                                                                                               
listen=YES                                                                                                                                      
#                                                                                                                                               
# This directive enables listening on IPv6 sockets. To listen on IPv4 and IPv6                                                                  
# sockets, you must run two copies of vsftpd with two configuration files.                                                                      
# Make sure, that one of the listen options is commented !!                                                                                     
#listen_ipv6=YES                                                                                                                                
pam_service_name=vsftpd                                                                                                                         
userlist_enable=YES                                                                                                                             
tcp_wrappers=YES                                                                                                                                
pasv_enable=YES                                                                                                                                 
pasv_min_port=2345                                                                                                                              
pasv_max_port=2355                                                                                                                              
listen_port=1024                                                                                                                                
pasv_address=ec2-xxxxxxx.compute-1.amazonaws.com                                                                                           
pasv_promiscuous=YES                                                                 

Note: i have already open those port in security group i mean listen port, min max

if someone shows me how to fix this i will be very greatful thanks

share|improve this question
add comment

2 Answers 2

up vote 3 down vote accepted

Either pasv_address needs to be the external IP address, or pasv_addr_resolve=YES needs to be set so that the hostname you entered will be resolved when vsftpd starts. If you use a hostname with pasv_addr_resolve, vsftpd has to be restarted if the IP address changes.

share|improve this answer
    
I just set my FTP client to use Passive Mode by default, but this should fix it on the server end of things. –  Chiggins Mar 11 '11 at 23:43
    
It's the server end of things that's wrong, that's why the server fails to go into PASV mode 500 OOPS: invalid pasv_address –  DerfK Mar 12 '11 at 1:36
add comment

pasv_address= IP address

you need an Elastic IP

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.