Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

It's been a few days now that I have gotten problems and problems with my network connection, though my other computer works fine!

The problematic computer is operating with (PC2)

Windows 7 Professional

The running-fine computer is running (PC1)

Windows Vista Business

The problem occured when I turned off my Cisco Catalyst 3500 series switch so that I can move it to another location (5 feet away). I then recoeecnted the Ethernet cables and my cable modem to the switch.

The PC1 then reinitialized the network, found the settings and reconnected properly! Internet is then running just fine as if I had never touched it in my life! Great!

I can't tell the same with PC2, sadly. It began to identify the network, then set it to Unidentified network over and over again though I have tried solving with the troubleshooter. Here's what I did so far:

I read this linked in answer article to know what's NLA.
What settings does Windows use to determine network location?

I have also read this: LAN - Unidentified Network (No Network Access) on Windows 7

I have also tried:

  1. Setting the DHCP Broadcast Flag to 0 so no more broadcast;
  2. Running a Powershell script that was suppoed to set all Unidentified network to private;
  3. Went and change manually Unidentified network setting from "unknown" to "private";
  4. Forced ipconfig /release, typed in a fake IP in my Local Connection, saved the seetings, then clicked the "Obtain an IP automatically option, and ipconfig /renew;
  5. Setting proper DNS IP though PC1 is set to obtain them automatically (and works, not PC2);
  6. Disabled the adapter, uninstalled and reinstalled it, and enabled it;
  7. To stop the NLA and related services with no luck (didn't solve my problem);
  8. Rolledback to previous working settings/configuration with a restore point, and it netiehr solved the problem.

Many of the above-mentioned tries come from and I simply can't find the questions anymore, so please believe me, I DID search! I've been working for about 6 hours on the problem, that is, probably becuase I am no network nor system administrator.

Any one who has something relevant is welcome to answer and help me. I'm desperate. =( I just want it to work!

While trying the ipconfig thing, it said that the DHCP request timed out. I tried to ping some other IP addresses as well, and it seems PC2 is totally lost. I can't find a solution, I have done everything I could, I knew, and learned for the last two days.

Thanks for your help!

share|improve this question
up vote 1 down vote accepted

The switch might be the problem here. If is a managed switch, here are some possibilities:

  • Pull the power for a minute
  • The switch was running a config that hadn't been saved. If the power was removed when you moved the switch, the config would have reverted so something else.
  • PC2 is on a different switch port and that port isn't configured the same
share|improve this answer
Agreed. And how can I diagnose it? It has already worked flawlessly so far. =( I'm gonna cry!... =P – Will Marcouiller Mar 12 '11 at 2:02
Just added some stuff to my answer. seraphim01 also has some good stuff. – poke Mar 12 '11 at 2:10
+1 Thank you for your input, poke. I have done what you're suggesting and nothing worked, though this was plausible. – Will Marcouiller Mar 12 '11 at 3:13
This was in fact a trouble due to my switch, it seems so. I have bought myself an Asus RT-N12 NAT and connected my cable modem into its WAN port, then plugged PC2 in, and the network connection worked a few seconds after. PC1 is still plugged into the switch and works just fine as well as it always did. Despite, I have kept the NAT and no more problems since! What is fun about this NAT is that it can serve a wireless repeater purpose. I can now connect my PS3 through wireless, though I shall buy a supplementary NAT for greater WiFi signal strength and quality. Thanks for your answer! =) – Will Marcouiller Mar 23 '11 at 23:03

It sounds like it may be an issue with the network hardware. Here are a few things to try:

  1. Does PC1 work fine using the same port on the switch? - this will verify the port is still functional
  2. Use the network cable from PC2 on PC1 - this will verify the cable is functional
  3. If both of the above check out fine try connecting PC2 to the switch using PC1's cable and port.


share|improve this answer
Thanks for your input seraphim01. I have tried the above except for PC1's cable into PC2's port, since cable is too short. Hence, I have tried PC2's cable into PC1 = OK. Connected PC1 to PC2's switch port = OK. Connected PC1 with PC2's cable and switch port = OK. Everything on PC1 works flawlessly. I really do believe it is software related, but then what? I can't tell. I read an article that said such problem could occur while connecting to wireless, some trouble caused by the wireless adapter. I have disabled it, and it changes nothing. – Will Marcouiller Mar 12 '11 at 2:49
+1 For taking of your time to help me. Thanks though it has not solved the problem. – Will Marcouiller Mar 12 '11 at 3:14

Instead of relying on DHCP to give you the correct IP settings, you may want to try to manually set the IP address, subnet mask and DNS server. Depending on how your network is setup, you probably just want to give your PC with the problems a private IP address but set the DNS server to the one your ISP is automatically giving your router.

Also, take a look at your routes (route print). You should have the default gateway route ( associated with the IP address of your default gateway and it should have the lowest metric.

If all that looks ok, ping the default gateway and you should get a response. If you don't, you can continue troubleshooting depending on the message you get back. If you can ping the gateway, try pinging the DNS server outside of your network. IF that works try doing an nslookup on

Turning off IPv6 if it's on is not a bad idea either. I hope this helps.

share|improve this answer
+1 I have tried this approach as well, though I guess I shall consider taking a deeper look at this. Thanks for your suggestion! =) – Will Marcouiller Mar 14 '11 at 0:26

protected by Michael Hampton Aug 14 '13 at 1:29

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.