Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have no idea what has gone wrong here. I have installed the audiotool sox, then tried to install the library libsox-fmt-all and all of a sudden apt-get refused to work. I cannot use it now, neither to update nor to install anything. Could somebody suggest what i could do to get it back to work? Here is the complete message it throws:

apt-get: symbol lookup error: /usr/lib/libstdc++.so.6: undefined symbol: _ZNSt7num_getIcSt19istreambuf_iteratorIcSt11char_traitsIcEEE2idE, version GLIBCXX_3.4
share|improve this question

1 Answer 1

It's possible that your apt somehow got corrupted.

You could try manually downloading the apt for 8.04 from the ubuntu package website and installing it with sudo dpkg -i filename_of_the_package.deb

share|improve this answer
    
I have tried that, didn't succeed... –  marue Mar 12 '11 at 18:37

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.