Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

What should be done to access Ubuntu apache server local url from virtual windows (VirtualBox OSE) machine ?

I have set virtual windows that can access ubuntu apache server, but after I delete windows.div with his folder and restore it - its not working any more.

Maybe I should give more permission to wrapper windows.div folder?

My computer:

computer OS :Ubuntu 10.04

virtual machine: VirtualBox OSE (I have 'Nat' option in network adapter)

virtual machine OS : windows xp


going inside virtual machine to firefox and inser url.

result: Server not found

but when i going directly in UBUNTU to i see homepage on my website

Thanks, Yosef

share|improve this question
Can you post the network configuration of your VM? – nickgrim Mar 13 '11 at 12:37
How can i find network configuration of my VM? – Yosef Mar 13 '11 at 12:46
i have 'Nat' option in network adapter – Yosef Mar 13 '11 at 12:54
up vote 2 down vote accepted

You need to add the IP address of the Ubuntu system (the host machine) to the Windows hosts file. It's location will vary depending on your version of Windows. See:

You'd add a line like this:


I think this should work in NAT mode, just check the default gateway of your network card under Windows.

share|improve this answer
thank you very much! – Yosef Mar 13 '11 at 13:23

You most likely have your guest setup to have NAT networking. You should configure your guest networking to be bridged. This will allow your client to obtain an IP address from your main network and then allow your client and server to communicate.

share|improve this answer
Thanks, I have Nat network, How can i test if Nat network working and if not, why not(maybe i should setup )? – Yosef Mar 13 '11 at 13:06
@Yose: It is easier if you can change the guest network to bridged. – Iain Mar 13 '11 at 13:10

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.