Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm a developer and I've installed Windows Server 2008 R2 on a box at home. I've set up a user and can connect to my home wireless router. I'm using the box to setup some version control and continuous integration. So I'll only need it on when I'm doing some developing. It won't be running nightly builds, only when I check code in.

I don't have a spare monitor or keyboard so I want to remote in to the server whenever I need to do anything on it. The problem is this: The server doesn't connect to the network until someone has logged in.

How do I set up the wireless so that when the machine is turned on?

It connects to the wireless network so I can remote in and use the other services. The only work around I have is not setting any password so the user logs in automatically. Then I can remote in no problem. This is less than ideal.

I'm not a server admin, so forgive me if there is a simple solution that I haven't found via Google.

EDIT

I'm not sure I made myself clear.

The server needs to connect to a home wireless network with a key. This only happens once a user is logged on. Ineed it to happen when the pc is turned on and no user is logged in yet.

Thanks, Tim

share|improve this question

closed as off topic by sysadmin1138 Jul 16 '11 at 17:05

Questions on Server Fault are expected to relate to professional server, networking, or related infrastructure administration within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

4 Answers 4

It doesn't make sense that the server doesn't make a network connection until a user logs in. There seems to be something else going on here. If it seems to work when a user logs in automatically, you can set this up to happen and also have a password.

In the registry under HKLM\Software\Microsoft\WindowsNT\CurrentVersion\WinLogon you can set the key "AutoAdminLogon" to 1, the key "DefaultUserName" to the correct user name, "DefaultDomainName" if needed to the local domain and "DefaultPassword" to the correct password.

This should just be used to get you by until you figure out the root of the problem. You should be able to RDP into this machine without having any user logged in, but at least having this user logged in and an appropriate password set it better that what you have now.

share|improve this answer

Try updating the wireless NIC driver or switching between the OEM vs. Windows wireless manager. There are some combinations that work better than others.

share|improve this answer

You will need to buy a wireless bridge or install dd-wrt on an old router and setup wireless bridge.

share|improve this answer

What you are looking for is to enable "Computer-only" authentication for 802.1x networks. This enables the computer to use the information that you would normally configure for a logged-on user.

How to enable computer-only authentication for an 802.1X-based network
http://support.microsoft.com/kb/929847

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.