Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have assigned all three NICs IP addresses that are outside the DHCP pool. I have 2 NICs are connected to 1 switch and the 3rd to my second switch.

I want to assign one of the two NICs on the 1st switch to "normal" network activity (e.g. internet access, RDP, etc.)

The other two NICs I want to reserve for mirroring ports on their respective switches.

While this machine is connected to the domain I can access the internet and Remote Desktop. I have no idea which NIC I am using until I start mirroring a port, at which time, if I happen to be connected through one of the NICs I have dedicated to mirroring, I lose my remote desktop.

Thank you for your assistance.

EDIT: I wish to capture packets on the NICs that I mirror ports on using Wireshark, Netminer, or NetWitness.

share|improve this question
up vote 0 down vote accepted

What kind of control would you have with Linux that you don't have with Windows?

Here's one way to do this:

Unbind TCP/IP from the NIC's you're using for port mirroring. TCP/IP doesn't need to be bound to the NIC for port mirroring to work.

share|improve this answer
My comment about Linux was to curtail a Linux vs. Windows troll match I am used to at the other forums I frequent. I will try your suggestion. – Hannibal Mar 14 '11 at 16:06
Your exhortation that you would have more control with Linux than with Windows is more likely to incite a Linux vs. Windows troll match than to avoid it. Keep us posted on your progress. – joeqwerty Mar 14 '11 at 16:34
Unbinding TCP/IP disabled their functionality in Wireshark and Netminer (see the edit in my original post) – Hannibal Mar 14 '11 at 16:34
That's strange. I run captures with Wireshark and several other packet capture programs with TCP/IP unbound to the NIC I'm capturing on without any issues. – joeqwerty Mar 14 '11 at 17:06
I stand corrected. I rebooted the machine and tried the capture again and it functioned normally. – Hannibal Mar 14 '11 at 17:48

Remove the Default Gateway from both NICs that you don't want to access the internet on.

share|improve this answer
I tried this suggestion as well.Thank you for your time. – Hannibal Mar 14 '11 at 19:50

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.