Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I am trying to connect to a new Windows Server 2008 R2 machine via RDP from a Server 2003 machine. I have (and would like to keep) enabled the requirement for NLA (Network Level Authentication) which is provided in RDP client 6.1. Unfortunately, RDP 6.1 doesn't seem to be available for Server 2003. Is there a way to do so without totally disabling NLA on the 2008 box?

share|improve this question
    
I have searched for this in the past. AFAIK the answer to this is no, NLA is not supported from Windows 2003 and there is nothing you can do to change that. –  Zoredache Mar 14 '11 at 19:42
    
If that is not available, is there a way to "selectively" disable NLA for particular clients? –  adamweeks Mar 14 '11 at 19:46

1 Answer 1

up vote 2 down vote accepted

As far as I know, NLA is not supported on Server 2k3 clients.

If you want, you can disable NLA by running tsconfig.msc on your 2008 R2 server, and deselecting the "Allow connection only from computers running Remote Desktop with Network Level Authentication" option under the RDP service.

share|improve this answer
    
Would rather not have to do that globally to only support one client. –  adamweeks Mar 14 '11 at 19:48
1  
You can set up another RDP listener on a second interface, and firewall that interface to only accept connections from a certain client. It's not an elegant workaround, but it would get the job done. –  Hyppy Mar 14 '11 at 19:50
    
Thanks for your help @Hyppy, its too bad Windows has dropped the ball on this. –  adamweeks Mar 15 '11 at 12:15

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.