Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Im trying to install WSUS SP2 on my SBS 2008 box and it just seems to hang at the "please wait whilst the setup wizard installs...." I left it there for 1 hour and nothing. WHen I canceled the install it just said failed. Reading up on this, it would seem there is a problem upgrading WSUS on an SBS 2k8 box - but no solution. Any ideas?

Thanks

share|improve this question
    
I'd look at Mitch's answer. Seriously. –  Holocryptic Mar 22 '11 at 19:59
    
Any updates? Interested to see how this ended up... –  Campo Apr 4 '11 at 20:51

4 Answers 4

If you look behind the dialog box asking you to wait is there another waiting for you to click next or begin?

share|improve this answer
    
HAHAHA if that is what it is I am going to eat my WSUS server... –  Campo Mar 15 '11 at 21:25
    
Hehhehe, not trying to be sarcastic or anything. : ) I did a cbt a few weeks ago and the guy presenting noted the "hidden" wsus dialog box. –  Mitch Mar 15 '11 at 23:22
    
I feel like I remember this from my WSUS instal. Was so long ago though.... The only thing that surprises me, is that I am still surprised. –  Campo Mar 16 '11 at 13:39
    
I've just installed WSUS (a couple times) and every time it hides the dialog box behind the server manager UI. So stupid... –  Holocryptic Mar 22 '11 at 19:58
    
Hey @Holocryptic! –  Campo Mar 22 '11 at 20:06

I just had the same issue. For me, the installation hung because the first thing the update does is a backup of WSUS database, which was 8GB, and it would run for 24hrs without finishing.

You can check that the backup is being created by looking in WSUS folder where a folder called {xxxx... should be created, which should contain a .bak file.

To get the upgrade working, I did WSUS 3 db optimization (found on Microsoft's website), then run the update cleanup wizard - this took almost 2 days to finish. In the cleanup wizard I did the first option separately (unused updates and update revisions) and then the rest.

After this I run the update and it took few hours to finish but it actually did. Then I shrunk the database and job done! The WSUS database is now 4GB.

share|improve this answer

So you already have WSUS installed on the box. Therefore is an upgrade? Have you tried to stop the WSUS service prior to doing the update?

NET STOP "Update Services"
share|improve this answer
    
Sorry yes its an upgrade... I'll give the stop the WSUS service a try and see what happens. –  Shabbaranks Mar 16 '11 at 10:41
    
Tried this last night and nothing. It still sits there, if I let it it would have been all night. There are no errors in the event viewer.. Annoying.. –  Shabbaranks Mar 17 '11 at 11:08
    
And as @Mitch said you did not see a hidden dialog box? Try using ALT+TAB to bring it up. –  Campo Mar 18 '11 at 14:49
    
Nope nothing. When it prompts to install it says "to start a new installation of WSUS 3 SP, please exit the upgrade wizard uninstall previous version and run setup again" But this is an upgrade not a fresh install. –  Shabbaranks Mar 18 '11 at 16:40
    
So do what it says.... The SP contains the full version WSUS and SP1 microsoft.com/downloads/en/… Similar size to SP2.... microsoft.com/downloads/en/… –  Campo Mar 22 '11 at 19:29

The SP contains the full version of WSUS http://www.microsoft.com/downloads/en/details.aspx?FamilyId=a206ae20-2695-436c-9578-3403a7d46e40&displaylang=en

From the MS site

WSUS 3.0 SP2 can be installed alone, or as an upgrade of WSUS 3.0 SP1.

If you cannot install as an upgrade and warning are asking you to unistal and instal fresh then that is what you should do.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.