Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

When trying to add a new user on a Debian 6.0 box I get:

passwd: User not known to the underlying authentication module

How can I disable Kerberos authentication and use the good old UNIX password?

share|improve this question
1  
How was it initially set up? Sounds like your PAM configuration is looking in the wrong place. –  Bart Silverstrim Mar 15 '11 at 13:00
    
Yes PAM seems to be messed up, this is a VPS server. I upgraded it with apt from lenny to squeeze I think that maybe screwed something. Not sure how to disable/remove PAM or fix it. I have never touched PAM before so it got the default settings. –  breez Mar 15 '11 at 13:36

1 Answer 1

you just have to: aptitude purge libpam-krb5 this package seems to be automatically installed while upgrading and after that it thinks you're running kerberos authentication... at least on my VPS.

share|improve this answer
    
Did the trick for me, thanks. –  MBober Mar 24 '12 at 10:03
    
Upgraded from Debian 5 to 6 and had this issue. –  deed02392 Jan 4 '13 at 19:06

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.