Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a service (statusme.com) where I let people know (for example) that their kid's soccer games are cancelled because of bad weather. We send out emails to the people who have registered.

I have a second server as a backup, (vps.statusme.com) and I've set up the application to send some of the email through the second server. But I'm getting complaints from various recipient SMTP servers that the email is considered spam. So I did some investigating, and it appears that they think my reverse DNS record isn't correct.

But when I look at it via various rDNS websites and instructions I found elsewhere on ServerFault, everything looks correct:

jb$ host -t a vps.statusme.com 8.8.8.8
Using domain server:
Name: 8.8.8.8
Address: 8.8.8.8#53
Aliases: 

vps.statusme.com has address 66.84.8.246

jb$ host -t ptr 246.8.84.66.in-addr.arpa 8.8.8.8
Using domain server:
Name: 8.8.8.8
Address: 8.8.8.8#53
Aliases: 

246.8.84.66.in-addr.arpa domain name pointer vps.statusme.com.

I'm confused about what I'm doing wrong. Thanks for any suggestions.

share|improve this question
1  
Is vps.domain.com masquerading as domain.com? Most mail servers have this option, their EHLO then contains "domain.com" instead of their normal host name. –  Chris S Mar 15 '11 at 13:32
    
How did you verify that the email was blocked due to an incorrect/missing PTR record? –  joeqwerty Mar 15 '11 at 19:29
    
Hi Chris - yeah, I have multiple servers because of the 'bursty' nature (i.e. thunderstorm == thousands of messages in a few minutes). Thanks for the advice re: EHLO, I'll give that a shot. –  johnbr Mar 17 '11 at 12:23
    
joe - I got a particular 571 bounce error from exchange, that I was able to track down and verify that my rDNS was in error. –  johnbr Mar 17 '11 at 12:25
add comment

2 Answers 2

up vote 0 down vote accepted

As, Chris S mentioned, make sure that name your server puts in EHLO header is the same as domain name. Then also check the following:

  • Make sure both of your server listed in MX record for the domain. Even though MX record is for receiving mail, many servers use it for anti spam measures.

  • Also, set up your (SPF record).

Hope this helps.

share|improve this answer
    
From working at an anti-spam company, I've discovered that >80% of domains don't bother checking SPF, and if they are checking MX records for receiving mail, they have a broken configuration. Very likely the HELO issue, although a bounce message would be useful to see. –  Ryan Gooler Mar 15 '11 at 16:22
    
What MTA's use MX records to validate the sending server? MX records determine where the email should go to, not where it should come from. Anyone using an MX record to validate the sending server is not very bright if you ask me. –  joeqwerty Mar 15 '11 at 19:27
    
In SPF record you can specify authorization against your MX record. But I have to agree - it is wrong statement for general cases. –  dtoubelis Mar 15 '11 at 21:15
    
Thanks everyone. I have updated the EHLO header @ vps.statusme.com, we'll see how it goes. I'll start looking at setting up SPF as well –  johnbr Mar 17 '11 at 12:26
add comment

Your prefered MX for statusme.com is statusme.com. not vps.statusme.com. And the A record for for statusme.com points to 72.249.74.167 (although admittedly it has a valid PTR record).

Are your recipients still failing to get messages for the same reason - certianly as Dimitri says, you should check the hostname used by the SMTP server - and configure SPF.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.