Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I tried FreeNX and NXClient connecting from my laptop to my deskop running ubuntu desktop over WAN(laptop and desktop has separate public ip each). I felt it's very fast and I want to use it as a best remote client.

I'm trying to connect from my home desktop to the office. In my office a single Dynamic public ip is used to access internet and all the systems are in LAN in the network 192.168.3.0 can connect to the internet. Does anyone know how could I connect to this private network of particular system(192.168.3.10) with FreeNX over WAN.

I was using ubuntu's shipped VNC which is dead slow and I've changed the default vnc port in the 'gconf-editor' and allowed the new port in the modem and I'm using it for now.

I have to connect to office system(192.168.3.10), what should I do?. If in my office it has only one system it wouldn't be any problem, I would've directly enter the dyndns domain name(registered for dynamic public ip for office) in the Host field of FreeNX.

  • Is any port should be opened in the modem(FreeNx was using 22)
  • What I should enter in the Host field of FreeNX?. Ofcourse dyndns domain name but how could I connect to the particular system of private network(192.168.3.10). It has the port option(default 22) and I tried it changing to my VNC port and it didn't work

Please anyone could guide me perfectly in connecting to my office system of the private network over WAN with NXClient?


EDIT 1:

I have two options in the Linksys router one is (1) port forwarding and (2) port trigerring. when using VNC I used port forwarding(5900 in the below) and I could connect to the server but no idea what with freenx, nxclient. what port I should open and in forwarding or triggering?

Port Forwarding:

Application  Start            End        Protocol   IP Address     Enable
ssh           22        to     22        BOTH       192.168.3. 2   yes
cvs           2400      to     240       BOTH       192.168.3. 3   yes
vnc1          5900      to     5900      BOTH       192.168.3. 5   yes
vnc2          5901      to     5902      BOTH       192.168.3. 10  yes

Port Triggering:

           Triggered Range              Forwarded Range             
Application   Start Port      End Port   Start Port        End Port       Enable
                          to                          to             
                          to                          to
                          to                          to
                          to                          to
share|improve this question
    
anyone has got any idea? –  user53864 Mar 17 '11 at 15:58

1 Answer 1

up vote 1 down vote accepted

You'll need the port to be forwarded at the office in order to connect to the internal IP. Overload NATs like the one your office uses disallow direct connections to internal addresses without port forwarding set up. The setup procedure for this is dependent on the router/firewall used at the office, but basically you'd reserve a port on the public IP, like 43210, to communicate specifically to 192.168.3.10:22. Then, you'd use your client to connect to (officeDynDNSEntry):43210

One other alternative is setting up a VPN, but that's way outside the scope of this answer. I'd point you towards http://openvpn.net if you want a good free VPN solution, though.

share|improve this answer
    
As I was/is using VNC, I allowed the port 5900(ofcourse changed it) in the modem for the system 192.1683.10 and so I'm able to connect using mydyndnsdomain.com:5900 via VNC. But not sure with FreeNX/NXClient as it didn't work when I tried the port 5900 in the port option of nxclient(selecting VNC instead UNIX in the nxclient options) –  user53864 Mar 15 '11 at 15:00
1  
You'll need to forward the chosen outside port to the internal IP on port 22 or whatever port you have FreeNX set up to use. –  Hyppy Mar 15 '11 at 15:07
    
I have edited my question! –  user53864 Mar 16 '11 at 16:32
    
Actually I didn't get you at the starting. I just changed the ssh port 5555 and opened it in the router. and it connected. Thanks a lot! –  user53864 Mar 18 '11 at 16:40

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.