Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I want to install ffmpeg from mediubuntu. I've installed the repository per the instructions on:

http://medibuntu.org/repository.php

My conf.d repository listing:

/etc/apt/sources.list.d# less medibuntu.list  
## Please report any bug on https://bugs.launchpad.net/medibuntu/
deb http://packages.medibuntu.org/ lucid free non-free #Medibuntu - Ubuntu 10.04 "lucid lynx"
#deb-src http://packages.medibuntu.org/ lucid free non-free #Medibuntu (source) - Ubuntu 10.04 "lucid lynx"

Yet when I install ffmpeg I still get it installed via the main ubuntu library.

/etc/apt/sources.list.d# apt-cache policy ffmpeg
ffmpeg:
 Installed: (none)
 Candidate: 4:0.5.1-1ubuntu1
 Version table:
   4:0.5.1-1ubuntu1 0
     500 http://archive.ubuntu.com/ubuntu/ lucid/main Packages

(Ignore the installed: none; I've installed/purged multiple times trying to get the medibuntu one)

Is there a way I can force it to use the medibuntu repository? Perferably at run-time rather than in a config file.

share|improve this question
    
If your apt-cache output is correct, it does not appear to be showing ffmpeg as even being present in any other repositories. Did you run an apt-get update? –  Zoredache Mar 15 '11 at 16:57

1 Answer 1

As Zoredache mentioned, it's not showing as available from anywhere but main; it needs to be there before this will work. That said, you'll want to look into using pinning to set the origin used for a given package.

Edit /etc/apt/preferences, and add a block something like this:

Package: ffmpeg
Pin: origin packages.medibuntu.org
Pin-Priority: 600
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.