Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a samba folder that I try and access through smbclient, and I can browse it just fine. However, mounting it through smbmount, all the folders under the share are empty. I can list the folders directly under the share fine, but they all appear empty.

smbclient:

# smbclient //server/share -U username -W workgroup password

smbmount

# sudo smbmount //server/share mntpoint -o user=username,workgroup=workgroup,password=password

I have also tried with domain=workgroup instead of workgroup, both give the same result. No error messages, everything mounts fine, but all the folders under mntpoint are empty, despite the same folders being non-empty when using smbclient.

Are these using different libraries? How can I debug the error?

Additionally, if I try to mount //server/share/folder, doing an ls results in a segmentation fault. Using dmesg I find:

kernel BUG at /build/buildd/linux-2.6.28/fs/cifs/cifs_dfs_ref.c:315!

Full trace: http://pastebin.com/m70adc213

Using a credentials file, I first get empty dirs, then Resource temporarily unavailable. In my dmesg I see the following output:

CIFS VFS: compose_mount_options: Failed to resolve server part of \\srv\share to IP: -11
share|improve this question

3 Answers 3

Try using a credentials file instead; see smbmount(8) for details.

share|improve this answer

Try to run this command :

mount -t smbfs -o username=username,password=password //server/shared_dir /mnt/

share|improve this answer
    
Per the manpage, mount -t smbfs calls smbmount -- so I wouldn't expect much difference. –  Joe Jun 12 '09 at 14:24
    
The mount works fine without workgroup, now I get the following error trying to list folders: ls: cannot access share/folder/: Resource temporarily unavailable –  Staale Jun 12 '09 at 14:24

While the difference in between smbclient and mount.{cifs,smbfs} did seem to indicate that this is a client issue (well, it might still be), what solved something similar for me was to update my smbd to the latest released package from my distro.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.