Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I setup a debian based server and installed subversion on it. After I configured the subversion client I did my first checkout. But I recognized a problem.

When I am using the svn protocol I can do a checkout without entering a username or password. But when I am using the http:// protocol I need to enter a username and password.

Now I want that I only can do a checkout when I have a correct username and password. Whatever which protocol I use.

In the /etc/apache2/ dir I created a .passwd file which is working and an .authz file.

In the .authz file I have

[groups]
developer = name

[/]
@developer = rw
* =

in my dav_svn.conf :

<Location /project1>
    DAV svn
    SVNPath /var/svn/project1

    AuthType Basic
    AuthName "bla"
    AuthUserFile /etc/apache2/svn.project1.passwd
    AuthzSVNAccessFile /etc/apache2/svn.project1.authz
    Require valid-user
</Location>
share|improve this question

migrated from stackoverflow.com Mar 16 '11 at 9:30

This question came from our site for professional and enthusiast programmers.

    
An (older) tutorial on setting up access control through the svn protocol can be found on Ubuntu's Server Guide and all the details are in the SVN Book. –  sarnold Mar 16 '11 at 0:01

1 Answer 1

Add a

Satisfy Any

Directive before the

Required valid-user

Correct it should be:

<Location /project1>
    DAV svn
    SVNPath /var/svn/project1

    AuthType Basic
    AuthName "bla"
    AuthUserFile /etc/apache2/svn.project1.passwd
    AuthzSVNAccessFile /etc/apache2/svn.project1.authz
    Satisfy Any
    Require valid-user
</Location>
share|improve this answer
1  
Ok thx for your response! I figured out my problem: In the file /var/svn/project1 I simply had to add anon-access: none –  xen100 Mar 16 '11 at 8:11

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.