Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have gotten a serios annoying question. The annoyingness of the question might come of the fact that it's beautiful weather outside, and that makes the office like a bakeroven. Not nice, when you are indoors.

oh well, back to the question.

I have set up a Windows server 2008 R2 with IIS and a FTP-server. I have set up a ftproot-directory with a drop directory directly below.

What I want to achieve is :

a) ftpuser gets access to the root directory. b) ftpuser can see the drop directory c) ftpuser can transfer file to drop directory d) ftpuser cannot see the content of the drop directory

Ftpuser gets access, and sees the drop directory. Ftpuser cannot see the content of the drop directory.

Problem is that I cannot transfer files from within Windows Explorer. I get a 550 Access is denied with: An error occurred. Please check that you can actually access the directory.

BUT, I have tried using FileZilla, and I can do anything above including D.

Why can't I use the builtin FTP-client in Windows XP or Windows 7, but I can use FileZilla to achieve the same thing?

Any good advice on how to rectify this?

Maclovable Maclovin

share|improve this question
    
Can it have something with passive / active connection to do? And how on earth do I rectify this? –  Maclovin Mar 17 '11 at 13:37

2 Answers 2

Assuming you have removed read access from the 'drop' directory, and you are attempting to visit: ftp://sitename.com/drop from within Explorer. If you just browse to ftp://sitename.com/ in Explorer (i.e. omit the drop folder portion), you should see the drop folder - then drag files to the drop folder but do not attempt to view the contents, which is what is generating the error.

share|improve this answer
    
That sounds plausible. But I can't have a system that generates errors, but still does the job. This is normal users who will panic and press the red button if they get an error. They will believe (no matter what anyone tells them, or whatever the documentation says) that they have not been able to upload the document (this is a document of equal importance to the world as the Dead Sea Scrolls, The Declaration of Independence, and Gutenbergs Bible), anda will press the red button, again or again, all the way in to a disaster of epic proportion happens. Can't have that, can we. –  Maclovin May 20 '11 at 7:01
    
Using FTP with no read access to the directory, will yield errors from some clients - there's nothing you can do about that - if it's unacceptable, then you may want to rethink the system and use a web-based file upload system rather than FTP. I've had a similar setup for years and it often causes some frustration, so you have to be very clear to users how it needs to be used. If your users are less technical, then I think a web-based setup may be more practical. –  barryj May 20 '11 at 7:50

Have you tried to access an explicit ftp:// URL or just ftp.example.com? Preferably even in the form ftp://ftpuser:ftppassword@ftp.example.com?

share|improve this answer
    
I have tried both accessing explicit and by getting a logon-window. I can't seem to be able to transfer file, but if I use FileZilla I can. –  Maclovin Mar 17 '11 at 7:10
    
Well, I think that I might have to bite the bullet, and install FileZilla FTP or some other program in order to accomplish this. –  Maclovin Mar 24 '11 at 7:58

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.