Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

On new or existing Citrix XenApp 4.5 servers, I am having problems streaming the Allscripts Pro EHR application via the XenApp web interface.

When users launch the application via the Citrix XenApp web interface, the application does not have focus, preventing users from typing in their username and password. If they use their mouse to select either the username or password fields, they still cannot enter any text.

However, if they do any of the following actions, they can then enter in their username and password and the application runs without problems:

  1. Click on the Login button with empty fields. Logon fails but they can then enter their credentials.
  2. Minimize the login window and then maximize it. They can then gain keyboard focus to enter their credentials.

What might be preventing this particular application from having focus when it launches?

share|improve this question
    
More detail. I created a VMware ThinApp of the application in question. The ThinApp version launches with focus locally and via RDP. But when I attempt to stream the ThinApp via Citrix XenApp (ICA), the login fields for the application lack focus. –  Jason Pearce May 16 '11 at 15:01

1 Answer 1

Try this: launch the app seamlessly via RDP instead of Citrix.

  1. Launch mstsc
  2. Go to Options and browse to the Programs tab
  3. Check the Start the following program on connection checkbox and enter the full path and working directory of the application or script you are launching
  4. Click Connect and login.

Observer the behavior of the application. If you see the same behavior, it is almost 100% certain that the problem is in the application, and 100% certain that it is not Citrix-related.

I have seen other applications behave this way when no other windows are present in the session. If another window is open in the session when the application launches, the behavior doesn't present.

share|improve this answer
    
Thank you J Rightly for this suggestion, as I hadn't considered it. Unfortunately, the application launches just fine (with focus) via this RDP method. It's a VMware ThinApp of the application. The ThinApp launches fine by itself or via RDP. But when I try to publish the ThinApp via Citrix XenApp (ICA), the login screen lacks focus. If I discover a solution, I'll be sure to share. –  Jason Pearce May 16 '11 at 14:59
    
You may want to try turning off seamless flags support.citrix.com/article/CTX101644 –  j.rightly Jun 29 '11 at 16:45

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.