Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've setup an Ubuntu image on VirtualBox on a Windows 7 host. On the Ubuntu guest I've installed Redis which runs on port 6379 (TCP) by default.

I've setup port forwarding using the VirtualBox GUI for SSH and verified that by connecting to localhost:2222 the connection is properly forwarded to port 22 and SSH works.

However, when I completed the same setup for port 6379 I get a "telnet: Unable to connect to remote host: Connection refused" error when connecting port 30000, which is setup to forward to 6379.

Just to verify that the Redis was running correctly I verified that I can connect locally (via the command line on the guest machine) to Redis using port 6379 (telnet localhost 6379) and successfully ran commands against it.

I'm at a bit of a loss as to why this is happening. Any input would be great.

share|improve this question
    
FYI - I also disabled the firewall on the host windows 7 machine for testing. –  meppum Mar 16 '11 at 19:42
    
What is the bind option set to in your redis config file. –  Rwky Mar 29 '11 at 13:19

2 Answers 2

up vote 3 down vote accepted

Find your redis.conf file and comment out the line that reads Bind 127.0.0.1. Most out of the box installs have the interface only excepting local connections. Once you comment that out and restart redis server you will be able to connect assuming no other firewall is keeping from getting in

On Ubuntu Linux you can go location /etc/init.d and issue the this command to restart redis server.

sudo ./redis-server restart

or

sudo  /etc/init.d/redis-server restart
share|improve this answer
    
conf file for me was at /etc/redis/redis.conf, found by find / -name redis.conf –  Peter Ehrlich Oct 29 '13 at 23:44

Check your /etc/redis/redis.conf, and make sure to change the default:

bind 127.0.0.1

to

bind 0.0.0.0

Then restart your service:

sudo /etc/init.d/redis restart

You can then now check that redis is listening on non-local interface with:

redis-cli -h 192.168.x.x ping

if you get PONG it's ok.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.