Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

We have just installed Windows 7 Enterprise x64 in one of our computer labs being used by students for programming. However, when we installed Visual Studio 2010 Ultimate on the machines, we found that to even launch the application (devenv.exe), required the student to enter the administrator password (the usual UAC prompt). Of course, we could just turn off UAC, but that would defeat the purpose of having it in Windows 7. On the other hand, we cannot really give the students local administrator privilege, as we are concerned that they will do some malicious stuff on the computers. Previously when we used Windows XP Professional running Visual Studio 2005, we had no problems.

Kindly advise if there's any workaround for this.


Thanks for the answer guys. Mayank, your links may work for Visual Studio .Net, but it doesn't seem to work for Visual Studio 2010. Ryan, Tieson, I'm intrigued that you guys managed to get it working easily. FYI I don't manage the Group Policies, but I can get them changed if necessary. Any particular GP that I should be looking at? Suggestions to how to troubleshoot further why UAC is being invoked? At least now I know for sure that this is not supposed to be the default behaviour for Visual Studio 2010 so I'm going to keep digging for a solution. Will try running Procmon and see if i can find something..

share|improve this question

migrated from Mar 16 '11 at 20:38

This question came from our site for professional programmers interested in conceptual questions about software development.

This might help you - Developing Software in Visual Studio .NET with Non-Administrative Privileges.

share|improve this answer
+1, this is the correct way to do it, i.e. adding the user to the debugger users group. – Bryan Mar 18 '11 at 8:29

OK, finally figured it out.. turns out we should NOT be running Visual Studio 2010 with administrator privilege. After we unticked that, it worked fine. Haha, we got too clever for our own good -_-"

Thanks to everyone who chipped in.

share|improve this answer

The IT staff here simply did a run-once and granted Visual Studio elevated privileges. So the application is running at Admin level, but the students are still only using Guest accounts.


share|improve this answer
-1: Have you tested this? What if a student clicks on 'file>open' and then changes the file filter to all files, surely they could then browse to any file and start it with admin rights? – Bryan Mar 18 '11 at 8:28

We have what sounds like the same environment as you. We have labs running domain joined Win7 x64 Enterprise systems with Visual Studio 2010 (among other software). Our users login with non-admin domain user accounts. I manage the group policy for these machines and we've purposefully tried to keep most of the Win7 filesystem/registry permissions as close to default as possible.

The Visual Studio install is pretty vanilla, but it runs without issue. No admin access is needed to launch or compile applications. Users can even debug standard applications and web applications in the development web server.

So I guess, what are the differences between our environments? Tieson's answer implied his users logged in with the Guest account...which is different than a normal user account and might be the reason for needing the admin access. What sort of group policy do you have applied to your machines?

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.