Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've been looking to virtualize my atom based server (This is the mobo: http://www.asrock.com/mb/overview.asp?Model=A330ION). I've tried to install ESXi and it couldn't detect my hard drives, I've tried Xen Server but I couldn't install Windows due to no VT-x. So my question is, are there any other alternatives that I could use? All I need is to be able to install are linux distro's such as arch and ubuntu and a windows machine (xp will do).

Cheers

share|improve this question

4 Answers 4

up vote 6 down vote accepted

Without VT-x support you really can´t run windows as a VM. Setting up Xen and running Debian or Ubuntu paravirtualized would probably work nicely, but the only way of getting windows into the mix would be to either run it (SLOWLY) via qemu or install windows on the machine itself and run for instance Virtualbox to handle the linux VMs. But even that would be far from optimal and probably very slow.

Without VT-x support, you really don't want to run any VMs without support for paravirtualization. In other words, no windows.

share|improve this answer
    
Well I am trying to move from running Arch with virtualbox running a Windows guest. –  Luke Mar 16 '11 at 22:24
7  
Luke, Atom's aren't designed for this, give it up, it's a bad idea, use a proper processor. –  Chopper3 Mar 16 '11 at 22:59
2  
I'm afraid Chopper3's got it - You're trying to run Crysis on a toaster. –  Chris Thorpe Mar 24 '11 at 8:18

I'm not sure if A330 supports virtualization, but if it does you will need to enable it in BIOS. Also, make sure your SATA controller is running in AHCI mode, this way you will have better chances with VMware. Other then that I agree with @Chopper3 - give it up :-)

share|improve this answer

well, i'm currently running virtualbox over a basic ubuntu server install. Its not as light as a standalone ESX I install but, well, it seems to work alright.

share|improve this answer

without VT you're stuck with emulation and not proper virtualization. Still, virtualbox or vmware ws/player should work.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.