Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Amazon recently introduced Windows Server 2008 R2 Core as an available image in EC2. I'm excited about this, but there is no documentation on how to get started.

For instance, how does one retrieve the default password for one of these instances?

share|improve this question
Have you contact Amazon about this? I strongly suspect they will know the answer. – John Gardeniers Mar 17 '11 at 6:43
I have, on their community forums last night, to no avail. – Dave Van den Eynde Mar 17 '11 at 7:40
Perhaps you should try and contact their technical support. I'm assuming of course that they do actually have technical support. – John Gardeniers Mar 17 '11 at 7:43
Of course they do, but it's paid support, and I'm looking for community support. – Dave Van den Eynde Mar 17 '11 at 8:23
up vote 7 down vote accepted

I've not actually used a windows instance myself, however i found this link:-

  • Right-click an instance and click Get Windows Password. The Retrieve Default Windows Administrator password dialog box appears.
  • Paste your private key into the provided field and click Decrypt Password. Amazon EC2 returns an encrypted version of the Windows Administrator password. Your private key is used to decrypt the password locally. Your private key will never be transmitted over the network.

Can't verify this though.

The amazon docs themsels have this:

Which means you can get it using

ec2-get-password i-2574e22a -k windows-keypair.pem

using the developer api tools.

share|improve this answer
That's the right way to retrieve the password for a Windows AMI, but the message I received was that there apparently was no password generated. This being a Server Core image threw me off at first, but I solved it in the end. – Dave Van den Eynde Mar 17 '11 at 12:22

I solved the problem by terminating the instance and launching a new one. Now, the password was easily retrievable.

Whether this is a problem that can occur to anywone, or exists because the AMI is really new and still under supervision, I don't know, but this solved it.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.