Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

my friend's company has a win2008 server, not R2, and it's really slow, it has 8G ram, has a SAP business one running on it, and it's also an AD, DHCP, DNS server, has Kaspersky 6 AV running as well. CPU usage is constantly 100%, physical memory is around 70%-90% even close everything, disable AV, if check processes, taskmgr.exe and windows explorer use like 40% each sometimes, do you have any suggestion what could be

share|improve this question
add comment

3 Answers

Yes.

  • Does it run SQL Server? Basically, does the AV package scan the database tables? That is a typical beginner / noop error.... they are constantly changing, every chagne triggers the av package.

  • Same for temp work directories, log files etc.

Basically anti virus ? heavy writing server = desaster. Db servers are VERY tricky on that as they write every change into the log files IMMEDIATELY (incl. flushing the drive caches to ensure it is persistent) and the files are large. This is constant rescanning of large files.

share|improve this answer
    
Thanks very much for the quick response, so what's your suggestion for the server that has sql dabase running, is it just excluse the sql folders or not run av at all, and disable any shared folers, thanks. –  andytimmons Mar 18 '11 at 0:02
    
Technically neither nor. All you need to exclude are all database files (mdf, ndf, ldf). In "real" serers they wont rely in the sql folders because thy are on separate discs. That said, a PURE sql server only has the admin folders and disc related foldes open anyway. disc blob storage is disputable (normally not so io heavy). Most people I know opf dont run ANY av on a server that has no user based files on it / no user disc access. But if you have to, at least make sure the database related files are not checked. –  TomTom Mar 18 '11 at 4:47
add comment

Is the AD server being used when this occurs?

Also, could you tell me some other specs, especially How many cores does the CPU have and at what speed does it run at?

From my knowledge,

It could be an issue with a broken windows account. So I'd try creating or just logging in with a new/different account

There is a problem with windows7 / 2008 r2 where broken .wav files can cause a lot of load in explorer.exe but since you mentioned not having r2 it couldn't be that...

share|improve this answer
    
it's my friend's company's server, the other day I had a quick look, I believe it's duo core e4500, I'm not 100%, but it's bought at mid of 2008. They had administrator account logged in all the time, with SAP, Filemaker, av open. Yes, AD is being used for user authentication –  andytimmons Mar 18 '11 at 0:20
add comment

Uninstall Kapersky and reevaluate the server. If I recall a colleague had issues with K6 and removing it solved the problem. If this works then check the Kapersky website for possible solutions.

share|improve this answer
    
Thanks for the comment, they were about to uninstall KASPERSKY,but realised they probably lost the key, they still remember the admin passwd for AV though, could they just uninstall the software, leave the config data, and when they reinstall, they wont need the key. Also since it's the av server, would uninstallation cause any drama for their av clients on all the PCs, again thanks for your help –  andytimmons Mar 18 '11 at 0:12
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.