Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

im installing exchange 2010 into a/d with an existing 07 installation

  1. im on a 64 bit server
  2. winodows 2008 R2
  3. 8gb ram
  4. All proper subnets are configured in the sties and services
  5. all domains are raised to a server 2008 functionality level.
  6. Logged on as the domain admin (schema admin, enterprise admin, etc.)
  7. Range setup /PrepareSchema, setup /PrepareAD, setup /PrepareDomain, no errors
  8. DCDIAG /A and DCDIAG /E show no errors
  9. All readiness checks passed seccesfully, no problems
  10. Double checked all PREREQS

i have it automatically install roles needed for exchange 2010

i have watched a couple video instructions on the installation and tried to see if im missing anything, everything looks fine.

whenever the exchange 2010 installation reaches the 'hub transport role, it keeps increasing the timeout and then fails to start the service. after it fails, I can start the service manually however.

Here is the LOGGED error:

[03/17/2011 18:18:56.0006] [1] Processing component 'Active Directory Topology Service Configuration' (Configuring Microsoft Exchange Active Directory Topology service).

[03/17/2011 18:18:56.0006] [1] Executing: 
          if ($exsSid -eq $null -or $exsSid -eq "")
          {
          $exsSid = get-ExchangeServerGroupSID -DomainController $RoleDomainController
          }
          start-setupservice -ServiceName MSExchangeADTopology -ServiceParameters $exsSid,$RoleDomainController


[03/17/2011 18:18:56.0006] [2] Active Directory session settings for 'start-SetupService' are: View Entire Forest: 'True', Configuration Domain Controller: 'WIN2K8DC1.JEWELS.LOCAL', Preferred Global Catalog: 'WIN2K8DC1.JEWELS.LOCAL', Preferred Domain Controllers: '{ WIN2K8DC1.JEWELS.LOCAL }'

[03/17/2011 18:18:56.0006] [2] Beginning processing start-setupservice -ServiceName:'MSExchangeADTopology' -ServiceParameters:'S-1-5-21-2134851818-3285922005-2538191131-3616','WIN2K8DC1.JEWELS.LOCAL'

[03/17/2011 18:18:56.0037] [2] Service checkpoint has progressed. Previous checkpoint='0' - Current checkpoint='1'.

[03/17/2011 18:18:56.0037] [2] Will wait '30000' milliseconds for the service 'MSExchangeADTopology' to reach status 'Running'.

[03/17/2011 18:19:26.0270] [2] Service 'MSExchangeADTopology' failed to reach status 'Running' on this server after waiting for '30000' milliseconds.

[03/17/2011 18:19:26.0270] [2] Service checkpoint has progressed. Previous checkpoint='1' - Current checkpoint='2'.

[03/17/2011 18:19:26.0270] [2] Will wait '1250000' milliseconds for the service 'MSExchangeADTopology' to reach status 'Running'.

[03/17/2011 18:40:16.0425] [2] Service 'MSExchangeADTopology' failed to reach status 'Running' on this server after waiting for '1250000' milliseconds.

[03/17/2011 18:40:16.0425] [2] Service Control Manager reports no process ID for service MSExchangeADTopology.

[03/17/2011 18:40:16.0425] [2] Unable to get the process ID for service MSExchangeADTopology because another similar process 0 was found

[03/17/2011 18:40:16.0425] [2] [ERROR] Unexpected Error

[03/17/2011 18:40:16.0425] [2] [ERROR] Service 'MSExchangeADTopology' failed to reach status 'Running' on this server.

[03/17/2011 18:40:16.0425] [2] Ending processing start-setupservice

[03/17/2011 18:40:16.0425] [1] The following 1 error(s) occurred during task execution:

[03/17/2011 18:40:16.0425] [1] 0.  ErrorRecord: Service 'MSExchangeADTopology' failed to reach status 'Running' on this server.

[03/17/2011 18:40:16.0425] [1] 0.  ErrorRecord: 
Microsoft.Exchange.Configuration.Tasks.ServiceDidNotReachStatusException: Service 'MSExchangeADTopology' failed to reach status 'Running' on this server.
[03/17/2011 18:40:16.0441] [1] [ERROR] The following error was generated when "$error.Clear(); 
          if ($exsSid -eq $null -or $exsSid -eq "")
          {
          $exsSid = get-ExchangeServerGroupSID -DomainController $RoleDomainController
          }
          start-setupservice -ServiceName MSExchangeADTopology -ServiceParameters $exsSid,$RoleDomainController
        " was run: "Service 'MSExchangeADTopology' failed to reach status 'Running' on this server.".

[03/17/2011 18:40:16.0441] [1] [ERROR] Service 'MSExchangeADTopology' failed to reach status 'Running' on this server.

[03/17/2011 18:40:16.0441] [1] [ERROR-REFERENCE] Id=AllADRolesCommonServiceControl___e95681b135f04f6ca85c706536bfbeed Component=EXCHANGE14:\Current\Release\Shared\Datacenter\Setup

[03/17/2011 18:40:16.0441] [1] Setup is stopping now because of one or more critical errors.

Help is appreciated :|

share|improve this question
    
Since the service failed to start, there might be more information in the Windows event log about why that happened; can you check for anything useful in there? –  Shane Madden Mar 17 '11 at 16:27
    
Process ExSetupUI.exe (PID=4292). An remote procedure call (RPC) request to the Microsoft Exchange Active Directory Topology service failed with error 1753 (Error 0x6d9 (There are no more endpoints available from the endpoint mapper) from HrGetServersForRole). Make sure that the Remote Procedure Call (RPC) service is running. In addition, make sure that the network ports that are used by RPC are not blocked by a firewall. –  Jeff Mar 17 '11 at 16:28
    
Maybe this book can help simple-talk.com/books/sysadmin-books/… –  adamo Mar 17 '11 at 16:29
    
i actually purchased and watched the trainsignal.com exchange 2010 training, i'll give the e-book a look though and see if it provides anything. thanks –  Jeff Mar 17 '11 at 16:35

1 Answer 1

up vote 3 down vote accepted

I've seen this issue twice before with two different causes:

  1. All IPv6 adapters were disabled. Enabling IPV6 on a NIC fixed it.
  2. The server wasn't in the Exchange Domain Servers group

After making sure both of these are good, you need to delete the Watermark and Action entries in HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Exchange\v8.0\Hub Transport and reboot before trying setup again:

No guarantees that one of these is the answer, but it's a start.

share|improve this answer
    
ipv6 is enabled on the NIC. should I set an IPv6 address? –  Jeff Mar 17 '11 at 16:33
    
I didn't need to. This just may not be what's causing your problem if it didn't fix it :-( –  Hyppy Mar 17 '11 at 17:12
    
im thinking about unjoining it from the domain, reinstalling everything, and trying this again. Not sure if the will cause problems the previous prepschema, prepad, and prepdomain however –  Jeff Mar 17 '11 at 17:15
1  
wait, i just got it passed the exchange transport role. your answer was right, i was looking at the members of wrong. it was listed in exchange servers, however it was not listed in exchange domain servers. i added that member shit, manually started the mxexchange topology, and the role installed sucessfully. Thanks for your help! –  Jeff Mar 17 '11 at 20:26
1  
No problem! Glad to hear it ended up being a simple answer and not a complicated AD hack. –  Hyppy Mar 17 '11 at 20:59

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.