Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

This should be a simple edit, but for some reason I am stumped.

We switched the ISP at a worksite.
For these purposes I'll post the new static IP info as:

IP - 10.1.1.50
Sub - 255.255.255.0
GW - 10.1.1.1

And the old info as:

IP - 10.2.2.100
Sub - 255.255.255.248
GW - 10.2.2.99

I have Replaced:

ip address outside 10.2.2.100 255.255.255.248

with:

ip address outside 10.1.1.50 255.255.255.0

and:

route outside 0.0.0.0 0.0.0.0 10.2.2.99 1

with:

route outside 0.0.0.0 0.0.0.0 10.1.1.1 1

But I am able to get out on the Internet.

What am I missing? Thanks in advance to anyone who can help shed some light on this,

The Pix config is as follows (with the lines above highlighted):

PIX Version 6.3(5)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
!enable password removed
!passwd removed
hostname firewall
domain-name ciscopix.com
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
object-group network xxxxxx
  description xxxxxx DHCP LAN
  network-object 192.168.1.1 255.255.255.255

access-list inside_outbound_nat0_acl permit ip 192.168.11.0 255.255.255.0 interf
ace outside
access-list inside_outbound_nat0_acl permit ip 192.168.11.0 255.255.255.0 192.16
8.1.0 255.255.255.0
access-list inside_outbound_nat0_acl permit ip 192.168.11.0 255.255.255.0 192.16
8.11.64 255.255.255.192
access-list outside_cryptomap_20 permit ip 192.168.11.0 255.255.255.0 interface
outside
access-list outside_cryptomap_20 permit ip 192.168.11.0 255.255.255.0 192.168.1.
0 255.255.255.0
pager lines 24
mtu outside 1500
mtu inside 1500
**ip address outside 10.2.2.100 255.255.255.248**
ip address inside 192.168.11.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool xxxxxx 192.168.11.50-192.168.11.100 mask 255.255.255.0
pdm location 192.168.1.1 255.255.255.255 inside
pdm location 192.168.1.0 255.255.255.0 inside
pdm location 192.168.1.0 255.255.255.0 outside
pdm location 192.168.11.64 255.255.255.192 outside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_outbound_nat0_acl
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
**route outside 0.0.0.0 0.0.0.0 10.2.2.99 1**
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout sip-disconnect 0:02:00 sip-invite 0:03:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
http server enable
http 0.0.0.0 0.0.0.0 outside
http 192.168.1.0 255.255.255.0 inside
http 192.168.11.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto ipsec transform-set myset esp-3des esp-md5-hmac
crypto dynamic-map dynmap 10 set transform-set myset
crypto map outside_map 20 ipsec-isakmp
crypto map outside_map 20 match address outside_cryptomap_20
crypto map outside_map 20 set peer xxx.xxx.xxx.xxx
crypto map outside_map 20 set transform-set ESP-3DES-SHA
crypto map outside_map 65000 ipsec-isakmp dynamic dynmap
crypto map outside_map interface outside
isakmp enable outside
isakmp key ******** address xxx.xxx.xxx.xxx netmask 255.255.255.255 no-xauth no-c
onfig-mode
isakmp identity address
isakmp nat-traversal 20
isakmp policy 10 authentication pre-share
isakmp policy 10 encryption des
isakmp policy 10 hash md5
isakmp policy 10 group 2
isakmp policy 10 lifetime 86400
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption 3des
isakmp policy 20 hash sha
isakmp policy 20 group 2
isakmp policy 20 lifetime 86400
telnet 0.0.0.0 0.0.0.0 inside
telnet timeout 5
ssh 0.0.0.0 0.0.0.0 outside
ssh 0.0.0.0 0.0.0.0 inside
ssh timeout 5
management-access inside
console timeout 0
dhcpd address 192.168.11.2-192.168.11.33 inside
dhcpd dns 216.41.101.15 204.17.65.2
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd auto_config outside
dhcpd enable inside
terminal width 80
Cryptochecksum:8fe81c86fdbead6054dfb67000337b15
: end
share|improve this question
add comment

4 Answers

How about those DNS servers? They don't seem to respond to queries from outside their network, may need to switch them to servers from the new ISP?

To verify, see if you're able to connect by IP.

share|improve this answer
    
Thank you for your speedy suggestion! I did not test that (it's a remote office and thus I cannot do so at the moment), however I was plugged right into the firewall and was receiving a 'No Internet Connection' warning. –  Dennis Mar 17 '11 at 22:23
add comment

I hate to ask the obvious but you did check the new connection was working? Our ISP had a problem, dispatched a contractor who instinctively replaced their router, declared it fixed and left. Many long calls later (my phone was flattening it's battery faster than the charger could charge) the ISP admitted they had not configured the new router to allow our router to talk to it. Check you have an internet connection on the outside of the firewall first.

share|improve this answer
    
Yes, I have the settings entered into a Router at the moment and it's working fine. –  Dennis Mar 18 '11 at 19:28
add comment

Have you bounced the firewall? What happens when you do a traceroute? You should see if your packets are getting past your PIX or your next hop gateway.

What happens if you (after-hours) grab a laptop and assign that new network config to it? That usually shuts up the ISP tech support when you suspect there's an issue upstream.

share|improve this answer
add comment
up vote 0 down vote accepted

Set proper DNS, bounced the downstream switch - working. Thanks to all!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.