Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Apparently the command for that is redistribute connected. Where do I input it? I tried it in the telnet interface, but it's not recognised.

share|improve this question

Connect to ripd daemon

telnet localhost ripd

If still not working or doesn't recognize ripd try

telnet localhost 2602


Then go in configuration mode

host# conf t

Then go into rip configuration

host# router rip

and run command

host#(conf-router) redistribute connected

Now press Ctrl+Z and save configuration

host# write


share|improve this answer
vtysh -c redistribute connected => unknown command. And I'm using the ripd daemon, not bgpd. – Czarn Mar 17 '11 at 21:24
Fixed. see now! – Sacx Mar 17 '11 at 21:40
Sorry, you misundertood; I can login to the telnet interface just fine. I enable it, but then the redistribute command is not recognised (it's not listed either). – Czarn Mar 17 '11 at 21:44
Did you forgot about configuration mode ? – Sacx Mar 17 '11 at 21:52
Still an unknown command in the config mode, still doesn't show up on the list. Also, doesn't this just save the settings to the config file? How would I put it there manually? Just putting redistribute connected raises an error when starting the daemon. – Czarn Mar 17 '11 at 22:03

You could add it to your ripd configuration file which is in /etc/quaga/ripd.conf. By the way you should have ripd service enabled and started…

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.