Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have configured an FTP server in IIS 6. I can access it by using ftp://localhost/. When I try I accessing it using static IP instead of localhost in a remote location, the page doesn't open. I am using Amazon EC2 instance. I have opened all ports for ICMP so I can ping to the static IP and port 21, 20, 1025-7000 are opened. I can open the page even if I disable the windows firewall. What changes must I make for it to work remotely ?

share|improve this question

2 Answers 2

Make sure that the site binding listens on the public IP for FTP, and not just 127.0.0.1. Try testing locally using ftp://{your_public_ip} to confirm that it's setup to listen on that IP. If it works locally but not remotely, then a firewall or proxy server in-between is blocking it.

Also, try briefly to disable the Windows firewall to confirm that it's not fighting with you. Or, better yet, enable logging and check the logs after a failed attempt. That way you don't have to disable the whole firewall.

share|improve this answer

I faced the same problem today, so maybe my answer will still be helpful for someone. All I needed to do was to add a security rule in my EC2 dashboard. The steps are:

  1. Go to EC2 dashboard
  2. Select Security Groups in the right panel
  3. Select HTTP rule in Inbound Rules tab
  4. Click Add Rule and then Apply Rule Changes
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.