Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have SQL 2005 SP4 installed on Win2k8. After I had it setup, we decided to change the name of the computer. In doing so, I think I might have broken something (possibly named pipes?) but I'm not sure as a) I'm not a DBA and b) I'm still in the process of setting this server up, so I can't say it was working before. And I really don't want to start over.

However, when I open up SSMS, the instance name shows the correct computer name, but under logins I have {OLDSERVERNAME}\SQLServer2005MSFTEUser${OLDSERVERNAME}$MSSQLSERVER and I think this is breaking my ability to do remote services connections.

So the question is, how to fix this?

share|improve this question
add comment

3 Answers

up vote 4 down vote accepted

There are considerations you need to be aware of for SQL when renaming the host machine. Do a

SELECT @@SERVERNAME

and see if it is returning the new machine name. If not, have a look through this MSDN article, follow the directions inside.

share|improve this answer
    
Thanks. I did as the article said, and the servername now comes back correctly. However, the users (named pipes?) still show the old server name in the path. Do I have to delete and recreate? Or am I missing something else? –  Holocryptic Mar 18 '11 at 17:35
add comment

exec sp_dropserver 'Oldname' go exec sp_addserver 'Newname', 'local' go

Then go to the SQL Server Configuration Manager and restart the SQL Server (MSSQLSERVER) service.

share|improve this answer
add comment

All of the logins will keep the same name and should work fine. If you want to you can remove them and re-add them. They keep working because SQL uses SIDs to match those logins and groups to the host OS and these SIDs haven't changed. Only the display information is incorrect. The Named Piped protocal itself should be working fine.

share|improve this answer
    
Thanks for the info. Now I just have to figure out why I still can't connect to the remote database. It's probably something stupid... –  Holocryptic Mar 18 '11 at 19:27
    
@Holocryptic See the section in the MSDN article I linked to regarding remote logins. –  squillman Mar 18 '11 at 22:25
    
@squillman Thanks. I overlooked that part because I didn't see that error when I dropped the server. At this point I burned the server down and I'm going to try fresh. Thanks for the help so far, though! –  Holocryptic Mar 18 '11 at 22:29
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.