Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

My setup is the following:

  • VMWare Workstation 6.5
  • Host OS - Vista Ultimate x64
  • Guest OS - Vista Ultimate x64
  • Notes - Both OS in same domain and using DHCP (and can talk to any machine on the network and over the internet fine)
  • Other special Notes - this is a newer laptop and the network adapter supports IPV6
  • Network Adapter - Bridged (with Replicate State checked)
  • Guest Isolation - VMCI is checked to allow host communication
  • The goal is to get both the Guest and Host to see eachother and the network.

I have tried the following with the following results (just pinging):

Disabled all network adapters on HostOS (except wireless) :
This works intermittently from the HostOS to the GuestOS (dropped packets), and doesn't work at all from the GuestOS to the HostOS ... however I did notice something strange when I ping the GuestOS(by name) on the GuestOS ... it successfully pings with IPV6 ... when I ping the GuestOS(by name) from the HostOS it seemingly uses IPV4. I disabled IPV6 on both adapters (Guest and Host) and received similar results and the GuestOS ping to the GuestOS looks something like this :::::::1 but it states that it was a successful ping.

Tried everything I did above, however, over the regular ethernet adapter:
Works like a champ no problems. However that weird self ping on the GuestOS still returns IPV6 responses.

Tried NAT with similar results.

share|improve this question
add comment

2 Answers

I don't have one to test on, but I believe you can't really get bridging to work over wireless, you have to use NAT mode or similar.

However, someone on Vmware's community site suggested this trick:

If you use the Virtual Network Editor, Automatic Bridging tab, and turn off Automatic, then select the adaptor you do NOT want to use it will switch to the other. So you would select NOT to bridge the non-wireless card.

share|improve this answer
    
+1 - you can't bridge a wireless card right now with VMware. NAT is the only easy way to go. –  Brent Ozar Jun 13 '09 at 0:40
add comment

I'm having trouble following exactly what you are trying to do, but :1 (with varying number of colons) is the IPv6 equivalent of 127.0.0.1 on IPv4.

If you suspect the physical adapters in the host OS are giving you problems manually install the MS Loopback adapter and configure it with a static IP and see how you go with that.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.