Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to build and install Zabbix 1.8 on my CentOS 5.2 server. This server has MySQL 5.0 installed from the standard CentoOS 5.2 repository.

./configure ... is failing because of:

configure: error: Not found mysqlclient library

When I do yum list mysqlclient* yum says there are no matching packages.

So I did a yum install mysqlclient* but get this error:

Transaction Check Error: file /usr/lib/mysql/libmysqlclient.so.15.0.0 from install of mysqlclient15-5.0.91-1.ius.el5.i386 conflicts with file from package mysql-5.0.77-4.el5_5.4.i386
file /usr/lib/mysql/libmysqlclient_r.so.15.0.0 from install of mysqlclient15-5.0.91-1.ius.el5.i386 conflicts with file from package mysql-5.0.77-4.el5_5.4.i386

How do I resolve this?

share|improve this question
add comment

3 Answers

up vote 4 down vote accepted

Install the mysql-devel package.

share|improve this answer
    
Thanks, this pointed me in the right direction. mysql-devel was already installed but it seems like the configure script didn't like it. I needed to do yum update mysql-devel instead which got me on my way. –  Kev Mar 19 '11 at 21:16
add comment

The mysqlclient library (libmysqlclient) is--as the error implies--already installed. Rather, it sounds like your paths are not setup correctly, which may be because the file is in a subdirectory of lib.

Try running configure with:

./configure --with-mysql=/usr/lib/mysql ...

You can also specify the path to mysql_config instead. If this continues to fail, you can explicitly set the library paths for configure, by setting environment variables:

LDFLAGS=/usr/lib/mysql ./configure ...

Leave feedback if this doesn't work, and good luck!

share|improve this answer
    
I did try both of those options but configure still failed. Ignacio's answer pointed my in the right direction. thanks for the answer though. +1 –  Kev Mar 19 '11 at 21:14
add comment

A sidenote about yum saying nothing is matches. My bet is you have a file that matches mysqlclient* in the directory you are running yum from. Try

yum list 'mysqlclient*'

Use apostrophes instead of double quotes because these interpolate and you would have the same problem.

share|improve this answer
    
Thanks for the tip. –  Kev Mar 20 '11 at 10:00
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.