Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I started a new service and we need to send emails to our customers (new account confirms, etc).

My server is known as prod01.bidrodeo.com and resolves to 97.107.134.38 . For reverse DNS, 97.107.134.38 resolves to prod01.bidrodeo.com . However, all our email addresses are in the form of user@bidrodeo.com. Should I make the reverse DNS point to bidrodeo.com instead?

My emails are getting delayed or rejected by certain systems and i am not sure if my reverse DNS is not set up correctly.

share|improve this question

5 Answers 5

up vote 17 down vote accepted

What you've got is "forward confirmed reverse DNS"-- that is, the named returned by reverse-lookup, when run thru a forward lookup, returns the same IP as the original IP used in the reverse lookup (see http://en.wikipedia.org/wiki/Forward_Confirmed_reverse_DNS for the more verbose description). That's a good first step.

The rejection messages are your best source of information about why your emails are being rejected. It looks like "prod01.bidrodeo.com" isn't listed as an MX for the domain "bidrodeo.com", and that's going to cause problems with some anti-spam techiques. I would consider configuring the proper TXT record for SPF (see http://old.openspf.org/dns.html) for this server computer and MXs for your domain. That's going to help with some email reception issues.

If you have examples of some of the rejections and have questions about them link them to the question.

share|improve this answer
    
Fantastic repsonse. I just added prod01 as an mx for the domain. Here are some rejects I am seeing a lot of: Helo command rejected: Host not found (in reply to RCPT TO command)) It could be that this particular recipient system has not updated its DNS cache and still has the old reverse DNS lookup... I just fixed reverse DNS for BidRodeo.com yesterday. Does that make sense? –  Kolibert Jun 12 '09 at 18:42
    
Actually, on my prev message, I do not want prod01.bidrodeo.com to be the MX for this domain. I am hosting my incoming mail on gmail. However, I would like to send email using my local SMTP server. Perhaps I should simply route everything through Google's SMTP server? –  Kolibert Jun 12 '09 at 18:44
    
Actually. scratch my above messages altogether. I just figured it out. In my postfix main.cf I had "myhostname" configured incorrectly. –  Kolibert Jun 12 '09 at 18:47
1  
What is the correct configuration of your "myhostname"? Is it "prod01.bidrodeo.com"? –  Lukas Schulze Feb 1 '12 at 20:11

Most SMTP servers will accept your mail if you simply have a reverse DNS entry. It does not have to match the domain name on your e-mail address. Some SMTP servers will reject mail if the reverse DNS doesn't match the HELO/EHLO hostname used in the connection. If your mail server's hostname is mail.example.com then your reverse DNS, MX record, HELO/EHLO, and SMTP greeting banner should all be mail.example.com as well. That server, however, could be providing service for example.com, joes-example.com, and marys-example.com without any problems.

Some other things to consider would be publishing an SPF record in the DNS for the domain name you use to send mail to identify the IP space you send from. Some larger providers look for this and give priority to mail coming from an SPF-enabled domain.

Also, keep an eye on the "reputation" of your IP address through SenderBase, as some providers will delay your mail or apply additional scanning/filtering if your reputation score is too low.

share|improve this answer

No, the server name and domain don't need to and rarely do match. Reverse DNS lookups simply ensure that the IP is a PTR record to the server name.

If you can post the headers/bounce messages of an example delayed or reject message, we should be able to narrow down why they're having issues.

share|improve this answer

That IP isn't on any of the major blacklists so that's not the problem. Without more info or perhaps some of the logs, the best suspect is that your HELO name doesn't match the server or doesn't resolve. In the course of sending mail your server will send helo $myservername (or whatever you've configured or have not yet configured) as part of the transaction with the receiving mail server. It is possible to configure a mail server to verify that the helo name exists in DNS and/or matches the reverse DNS.

share|improve this answer

If this is a recent server, it's possible that DNS has not fully propagated.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.