Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Using a preseed file for Ubuntu 10.10 alternate, I am unable to skip pass the "Origin of keyboard" question. Any ideas why? My preseed file is as below Reference link here

#### Contents of the preconfiguration file (for squeeze)
### Localization
# Preseeding only locale sets language, country and locale.
d-i debian-installer/locale string en_US

# The values can also be preseeded individually for greater flexibility.
#d-i debian-installer/language string en
#d-i debian-installer/country string NL
#d-i debian-installer/locale string en_GB.UTF-8
# Optionally specify additional locales to be generated.
#d-i localechooser/supported-locales en_US.UTF-8, nl_NL.UTF-8

# Keyboard selection.
# Disable automatic (interactive) keymap detection.
d-i console-setup/ask_detect boolean false
d-i console-setup/modelcode string skip-config
d-i console-setup/layoutcode string us
# To select a variant of the selected layout (if you leave this out, the
# basic form of the layout will be used):
#d-i console-setup/variantcode string dvorak 
share|improve this question
    
I ran into this problem as well a couple years ago and never found a solution. ale.org/pipermail/ale/2008-March/101004.html –  sciurus Mar 21 '11 at 15:56
    
It seems we were not the only ones, definitely needs a ticket. –  vener Mar 22 '11 at 5:46
add comment

2 Answers 2

up vote 1 down vote accepted

just adding in a comment here, hope it helps a little bit...

I managed to get past this same issue by putting my settings in the boot default file for my pxe launch, as following: vi pxelinux.cfg/default:

default install

label install

    menu label ^Install

    menu default

    kernel ubuntu-installer/i386/linux

    append ramdisk_size=14984 locale=en_US console-setup/ask_detect=false  console-setup/layoutcode=us  netcfg/choose_interface=eth1 netcfg/get_hostname=testserver url=http://10.255.0.1/ubuntu-preseeds/preseed.cfg vga=normal initrd=ubuntu-installer/i386/initrd.gz -- quiet

I hope that helps a little bit, sorry about the mess :)

Cheers, Karl Kloppenborg.

share|improve this answer
    
Unfortunately, it didn't work –  vener Mar 24 '11 at 19:10
    
Hi Vener, I ended up working it out, I have posted a version of it on my company blog, have a look and give it a try :) –  Karl Kloppenborg Mar 25 '11 at 0:08
    
crucial.com.au/blog –  Karl Kloppenborg Mar 25 '11 at 0:09
    
I take back what I said, I appears there was an error in the build script when I tried out this method, the VM ended up using an old .cfg It works. Thanks –  vener Mar 25 '11 at 8:06
    
No problem ;) Hopefully everything would be working nicely by now! –  Karl Kloppenborg Dec 22 '11 at 12:19
add comment

from: http://askubuntu.com/questions/89185/what-is-the-correct-way-of-setting-up-an-abnt2-keyboard-layout-in-preseed/258570#258570

AFAIK you need all of

d-i     keyboard-configuration/variant select English (US)
d-i     console-keymaps-at/keymap select us
d-i     keyboard-configuration/xkb-keymap select us

and possibly

console-setup/ask_detect=false console-setup/layoutcode=us keyboard-configuration/xkb-keymap=us

on your append line of txt.cfg (or whatever isolinux config)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.