Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I am trying to access IIS 7.5 server on Windows server 2008 with windows Aunthentication enabled but after login info pop-up i see login credentials are failing with the error "401 - Unauthorized: Access is denied due to invalid credentials". I am able to browse the file from IIS server but can not open it remotely. Any pointer with regard to this issue will be helpful.

share|improve this question
    
Is it a domain server? If so, are you connecting with a local account or a domain account? If it's a domain account, are you using the domain\username or username@domain to login? –  Hyppy Mar 21 '11 at 12:06
    
IIS server is on a new Domain. Client which is trying to access this IIS server is on the same domain. As lohin username i am using <Domain-Name>\<Client username in DC>. –  Manish Shukla Mar 21 '11 at 12:16
    
Can you edit your post and add any relevant lines from your event log or IIS logs? This is where the real errors will be; The 401 is just saying "I didn't work. Call the person who wrote me." –  Hyppy Mar 21 '11 at 12:22
    
You shouldn't be seeing prompts for a client on the same domain when using Integrated Windows authentication - that suggests auth was tried once and already failed, unless you're using an FQDN to access the server, in which case, don't. Does it still happen if you use the actual short server name (not an alias) from a client computer? (And: Have you set SPNs or done anything else that might affect Kerberos authentication?) –  TristanK Mar 21 '11 at 12:32
    
I have tried with short server name (hostname) but it did not pass the problem. And yes i have set SPN. –  Manish Shukla Mar 21 '11 at 12:41

1 Answer 1

Does the user you're authenticating as have access to the files you're trying to access? The file system ACLs must allow access for the authenticated user.

share|improve this answer
    
Yes, user have read access to files. –  Manish Shukla Mar 21 '11 at 12:42

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.