Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm needing to setup a basic web user account on my ubuntu 10.10 server to host web pages. This account should be limited to access only the necessary directories on the machine. I setup the following account but nothing happens when I try to log into it:

:~$ groupadd -g 1005 webgroup
//I then changed the group and permissions of a current user I had already created
:~$ sudo usermod -g 1005 -s /bin/false -d /home/webuser/ webuser

When trying to login using this account I enter the username [webuser] and the password but it just redirects me back to the login: prompt. I tried resetting the password but still have the same problem.

Can someone either tell me what I'm doing wrong, or suggest another method that would achieve the same result (if not a better one).

share|improve this question

1 Answer 1

up vote 2 down vote accepted

You're getting kicked back to the login: prompt because the shell is set to /bin/false. That's not a bad idea for any user that shouldn't allow logins (you should really use /sbin/nologin), but you'll need to change it to a valid shell like /bin/bash to log in with that account.

share|improve this answer
    
+1, Good call with /sbin/nologin –  Hyppy Mar 22 '11 at 0:25

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.