Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I followed the tutorial at http://www.debian-administration.org/articles/412 and I did everything it said but my site isn't showing it just says "Unable to Connect" when I try and visit the address in my browser.

I am using Apache2.2 on Debian Lenny. I have multiple IPs/RDNS configurations on this server, and I know for a fact that they all work. How do I fix it? My httpd.conf is empty, my apache2.conf and ports.conf are the defaults. Here is what my sites-enabled configuration for my site looks like:

    <VirtualHost *80>
    ServerAdmin mysite@mydomain.com
    ServerName  www.mydomain.com
    ServerAlias mydomain.com

    # Indexes + Directory Root.
    DirectoryIndex index.html
    DocumentRoot /home/user1/www/www.mydomain.com/htdocs/

    # CGI Directory
    ScriptAlias /cgi-bin/ /home/user1/www/www.mydomain.com/cgi-bin/
    <Location /cgi-bin>
            Options +ExecCGI
    </Location>


    # Logfiles
    ErrorLog  /home/user1/www/www.mydomain.com/logs/error.log
    CustomLog /home/user1/www/www.mydomain.com/access.log combined

`

share|improve this question

migrated from stackoverflow.com Mar 22 '11 at 9:24

This question came from our site for professional and enthusiast programmers.

1 Answer 1

You should have a colon between the asterisk and the port number in the VirtualHost directive.

Such as: <VirtualHost *:80> You should also have a closing "tag": </VirtualHost>.

Also check the log files to see what more is wrong.

netstat -nap|egrep -e 'apache|httpd' should show you what port and IP address apache is listening on, if it is up.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.