Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a W2K8R2 Server Core install with the DNS role. I want to disable recursion on this server as it exists only to respond to DNS requests for which it is authoritative.

I have run the "dnscmd /config /norecursion 1" command and dnscmd /info shows fNoRecursion with a value of 1, that is, do not do recursion. My forwarders list is also empty, although I don't think that even matters if I'm not doing recursion. I have cleared the cache and stopped and restarted the DNS service.

However, if I connect to this server from a remote machine the server is doing recursive lookups for me. I can connect to it and ask it to resolve www.cnn.com and it will do so. Any ideas?

share|improve this question

1 Answer 1

up vote 4 down vote accepted

Have you tried deleting root hints?

share|improve this answer
    
That did it. I even tried setting IsSlave first and it still did resolution. It wasn't until I deleted the root hints file (%systemroot%\system32\dns\cache.dns) that it no longer did resolution. –  WaldenL Mar 22 '11 at 18:29
1  
Sadly this strikes me as wrong as effectively the server is trying to do lookups but is unable since it has no root hints, vs. not trying to do them in the first place. But the net effect is the same. –  WaldenL Mar 22 '11 at 18:30
    
Create a . zone then. –  Vick Vega Sep 10 '13 at 20:57

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.