Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have Debian Squeeze and I have cpp-4.3 which sits on it:

enter image description here

I want to know if I can remove cpp-4.3 and others and install something like cpp-4.4 or higher.

And why does aptitude does not upgrade cpp to 4.4 automatically?

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

There are three versions of gcc (including cpp) in Debian squeeze: 4.1, 4.3 and 4.4. You can install all of them if you like. I recommend installing the cpp package; it has cpp-4.4 as a depency, but when the next Debian version comes out, its cpp package will depend on whatever version is the newest then.

cpp-4.3 is marked as automatically installed, so if you remove all the packages that depend on it, it will be automatically uninstalled as well. At the moment, you have gcc-4.3 installed, and it depends on cpp-4.3. You also have g++-4.3 marked as manually installed, and it depends on gcc-4.3. Unless you know you want GCC 4.3, mark g++-4.3 as automatically installed, and make sure you have gcc and g++ installed.

After you've done this, consider removing the -4.3 packages and any other old version. Some packages will not be removed automatically even if they are marked as automatically installed and nothing depends on them specifically. That happens when some other package depends on a meta-package they provide. All C compilers, including gcc-4.3, provides c-compiler, so as long as you have a package that depends on c-compiler, gcc-4.3 will not be automatically removed. You can remove it manually; try it and check that nothing depends specifically on this version.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.